3

I am trying out different distros. However, my laptop has ATI GPU (Asus N56D) due to which many distros didn't boot successfully. After having google'd I found that I need to set "NOMODESET" kernel parameter.

I could edit the grub command line (by pressing 'e' at the grub) but unable to boot after pressing Ctrl+X or F10. Pressing Ctrl+X merely results in adding character 'x' at the cursor position. (This happens irrespective of linux distro).

Due to this I am unable to boot with the kernel parameter.

7
  • Are you able to get it boot without your additional parameter? And also, it's nomodeset, no nomodset. – user37607 Dec 6 '13 at 9:58
  • @RistoSalminen Without additional parameter I can proceed further, but drops into shell prompt and no GUI. – Vaman Kulkarni Dec 6 '13 at 11:07
  • So it happens only when you have set nomodeset parameter to kernel, that pressing Ctrl-x just adds 'x' there? – user37607 Dec 6 '13 at 11:08
  • Yes..thats right. After editing I am not able to get those changes into effect since Ctrl-X doesn't work. I had to press Esc to discard changes. – Vaman Kulkarni Dec 6 '13 at 12:28
  • Well, that's such an interesting behaviour. I think this should be possible: when you have edited the cmdline, just press Enter and then b. – user37607 Dec 6 '13 at 12:38
2

I had the same problem and the following worked out:

Ctrl+Shift+fn+F10

0

I had same problem with serial connection to embedded device using putty. Solved it by turning terminal emulation setting to VT400 and using F10. Seems like with default settings it sends Esc instead of functional keys.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.