1

My external hard drive was acting strangely, so I ran badblocks, and it seemed that nearly every block was bad from the first minute I ran it. If I did badblocks -v > file, the file was over 100MB after only seconds of running it.

Then, for the hell of it, I ran badlocks on the same drive without using the 10 foot USB3 extension cable I've been using, and it's at 5% with no errors.

Also, if I interrupt badblocks with the cord, it will show up as a different drive name (/dev/sdb, run badblocks and quit, and the drive is now /dev/sdc), and I haven't been able to reproduce this without the cord.

Is it possible for badblocks to be wrong and complain about a perfect drive?

4

Sounds like you have a bad cable. The drive renaming itself is indicative of the USB connection being dropped and restarted and the kernel assigning the next device name to the subsequent connection.

I'd watch dmesg for USB errors while accessing the drive. If it works with the short cable, that further reinforces your long cable is bad. Also keep in mind that 10 feet is essentially the max length for a USB3 cable and any deficiency in the electronics on the motherboard or the USB hard drive is going to be amplified by using a cable that long. So, could be bad cable or it could a cheap USB controller in the drive. Recommendation is the same: use a shorter cable.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.