3

I created a bare git repository and pushed to as root. Then I ran su myuser and ran the following commands:

$ whoami
myuser
$ mkdir t
$ cd t
$ git clone ssh://myuser@mybox.net:1234/git3

Cloning into git3...
myuser@mybox.net's password:
fatal: '/git3' does not appear to be a git repository
fatal: The remote end hung up unexpectedly

$ git clone /home/myuser/git3
Cloning into git3...
done.

Why is ssh failing? I can clone it by using the local path, and whoami shows myuser -- I am not root. Just to make sure I have the addr right I wrote ssh myuser@mybox.net -p 1234 by copy/pasting the info rather then typing it.

I don't understand why ssh isn't working. I know i had it working on this remote box, but I upgraded from debian lenny to squeeze and recently I made various config changes. I don't understand why I can't use git with ssh here.

6

erm, don't you need:

$ git clone ssh://myuser@mybox.net:1234/home/myuser/git3

??

  • sigh. That solved it. i KNOW i tried that already. I must have tried it before i thought of checking the folder permission (i accidentally made it root) – user4069 Mar 31 '11 at 13:57
  • 1
    What a great UI. – Jürgen A. Erhard Oct 19 '12 at 10:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy