1

Trying to execute the command

svn log svn://[my server address]/path/to/repository

nets me the following:

svn: E170001: Unable to connect to a repository at URL 'svn://[my server address]/path/to/repository'
svn: E170001: Could not create SASL context: generic failure

Some quick googling reveals a possible solution:

sudo port activate cyrus-sasl2 @2.1.23_3+kerberos

However, before I attempt this, I would like to know a couple things.

  1. What exactly is going on?
  2. What does this command do? How does it fix the problem?

EDIT: I am not using SASL, nor do I wish to. I don't actually have Cyrus SASL installed.

  • You're on Ubuntu, does the port command actual exist there? I didn't see it on 12.10. – slm Dec 5 '13 at 2:15
  • BTW, port is an OSX command for the ports package manager, so that isn't your issue here. – slm Dec 5 '13 at 2:52
0

I believe this is a known issue with these particular versions of the cyrus-sasl2 libraries. Try updating to a newer version of the libraries and/or downgrade to an older version if the latest does not resolve your issue.

I found the following issues that were raised regarding this issue in both a Fedora bug tracker as well as a Debian one.

  • Does SVN run through cyrus-sasl2 regardless? Because I have SASL disabled on the server.... – MirroredFate Dec 5 '13 at 18:26
  • @MirroredFate - read the SASL section of the manual. Your server is the one advertising this: svnbook.red-bean.com/nightly/en/svn.serverconfig.svnserve.html – slm Dec 5 '13 at 18:29
  • It says to activate SASL you have to have the line use-sasl = true, which I have commented out.... The only security I have the server configured to use is the CRAM-MD5.... which is why I am so confused.... – MirroredFate Dec 5 '13 at 18:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.