1

Trying to setup memory usage monitoring for Nagios using the check_snmp_mem.pl from Nagios SNMP plugin.

I could not even get it working from the command line, I mean I go to /usr/lib/nagios/plugins and run the script, it gets a "No response from remote host" error.

[root@nagios plugins]# ./check_snmp_mem.pl -H rhel01 -C public -N -w 90,20 -c 99,30
Argument "v6.0.1" isn't numeric in numeric lt (<) at ./check_snmp_mem.pl line 319.
ERROR: Description table : No response from remote host "rhel01".

Any SNMP configurations required on the monitored server?

  • Yes, you do need to have snmpd enabled and running on the remote host and configured to allow the Nagios server to contact it. Try using snmpwalk to test the snmp service. – bahamat Dec 3 '13 at 6:33
1

With help from another colleague, we worked out why it didn't work.

3 things:

  • First, we have agentaddress tcp:x.x.x.x:161 in snmpd.conf, just deleted the line
  • Second, iptables is blocking udp port 161, added rules to allow udp port 161
  • Third, something wrong with the script as you can see the error message about line 319, changed < to lt

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.