While attempting to use an old 40GB HDD to setup a kind of junky though usable Athon 1GHz system I ran into the following error during the HDD identification/partitioning phase of the installation:

Warning: Disk sda contains BIOS RAID metadata, but is not part of any recognized BIOS RAID sets. Ignoring disk sda

How can I work around this issue?

  • I would assume that dd if=/dev/zero of=/dev/sda bs=1M count=100 or something similar would have worked as well (that nukes the first 100MB of the disk - I don't know where the RAID data is actually kept). – Aaron D. Marasco Dec 3 '13 at 3:26
  • @AaronD.Marasco - you're probably correct, but it seems better to use actual tools to do this type of work rather than take dd to the disk, no? – slm Dec 3 '13 at 3:43
  • Most definitely; that's why mine was a comment not an answer. I was giving a command that I've used in the past to nuke all the partitioning information, etc. – Aaron D. Marasco Dec 3 '13 at 9:53

I found the solution to this issue in the following thread titled: [SOLVED] CentOS 6 on GA-990FXA-UD5.

The solution involved removing the BIOS RAID metadata that apparently was part of a residual software RAID that the 40GB HDD must of been used in. Running this command in the CentOS 6.5 LiveCD in a terminal fixed it:

$ dmraid -r -E /dev/sda
Do you really want to erase "pdc" ondisk metadata on /dev/sda ? [y/n] :

To which I replied "y".


This failure is a little unnerving since it occurs while running the Anaconda installer tool that's typically used by all the Redhat products (CentOS/Fedora/RHEL) and the failure is not graceful.

I'm not sure why, but Anaconda cannot deal with this situation itself, and it leaves you in a state where you can see the "verbose" debug output, which was far from helpful.

I saw no other way around the issue from within Anaconda.

| improve this answer | |
  • 1
    A very small addition: You can run the dmraid command directly from the CentOS 6.5 install media by using CTRL+ALT+F2 to switch to the anaconda shell tty / terminal. This saves burning a separate LiveCD. – plasmid87 Jun 26 '14 at 13:33

This unsupported pseudoRAID setup causes RHEL6's Anaconda to get stuck during the installation process as well. The workaround is pretty easy, though -- simply adding the nodmraid option to the kernel command line allows the installation to carry on.

To make this modification, hit the Tab key when the CD's bootloader menu comes up, and add nodmraid as an extra argument. In my opinion it is a bit unfortunate that Anaconda decides to ignore these drives even when explicitly asked to nuke their contents via the clearpart --all --initlabel --drives=... stanza.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.