1

I am trying to copy files from my hard drive to a networked external disk (WDMyCloud). I have enabled the FTP access to the hard drive and mounted it to a local directory using curlftpf to a local directory. Now I created the directory I wanted to copy the files to in the mounted directory and tried

rsync -avzP /media/Windows7_OS/Work/* .

which resulted in rsync copying for a long time, showing progress and very good transfer speeds, but at the end the target directory only contained .Files.ext.kE5WT or something similar, that corresponded to the names of the files in the source folder but all of them had 0 length. cp copies without problem, although the transfer rate is slow. I am on CentOS 6.4.

Where did I go wrong?

  • Did you try rsync -avzP "/media/Windows7_OS/Work/*" ., or rsync -avzP /media/Windows7_OS/Work/ .. The * might not be doing what you expect. – Bernhard Dec 2 '13 at 12:13
  • sadly /media/Windows7_OS/Work/ without the asterisk produces the same result .. – amirzolal Dec 2 '13 at 13:05
  • You don't need the *. rsync interprets a trailing / at the end already as directory content. – scai Dec 2 '13 at 13:06
  • I suggest that if its an FTP server, you use nfctput, etc. Use an FTP client. It'll work better. Or if it can, export via NFS or even CIFS/Samba (Windows file sharing). Both will work better. – derobert Dec 2 '13 at 13:12
  • wdc.com/wdproducts/library/UM/ENG/4779-705103.pdf tells me it supports NFS and CIFS. If you want to copy from Windows, export the destination with CIFS. If you want to copy from Linux, export with NFS. – derobert Dec 2 '13 at 13:21
0

This looks like a bug in CurlFTPfs, perhaps compounded by some missing error checks in rsync.

You can enable SSH access on this device. Rsync over SSH is a lot more likely to work out of the box, and some people have reported success.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.