9

I've seen many threads about this error but I couldn't find a solution. I've installed Arch Linux alongside Windows 8. (Dual Boot).

I followed this video exactly but am getting the error below at 20:35. After a reboot I'm getting:

error: no such device: ad4103fa-...
Loading Linux core repo kernel...
error: file `/boot/vmlinuz-linux` not found
Loading initial ramdisk ...
error: you need to load the kernel first.

Any helps would be great.

4
  • If you want to install Arch, use the official documentation or the Beginners' Guide, not some random video that is likely both outdated and incorrect...
    – jasonwryan
    Nov 30 '13 at 18:36
  • That video is about year 2013 Nov 30 '13 at 18:40
  • 6
    That doesn't mean that some guy with a hip hop soundtrack and an inability to complete a sentence installing Arch in a Virtual Machine will be of any help to you. Read the documentation provided by the community; if you aren't prepared to do that for the install, there is no reason to believe you will enjoy/understand Arch.
    – jasonwryan
    Nov 30 '13 at 18:42
  • 1
    @jasonwryan Thank you. The problem was solved. Nov 30 '13 at 19:40
20

I found the answer.

Put Arch DVD or Flash Drive and boot it again.

Retry following commands :

mount /dev/sda1 /mnt #sda1 is `boot` partition
mount /dev/sda3 /mnt/home #sda3 is `home` partition
arch-chroot /mnt
pacman -S os-prober
grub-install /dev/sda
grub-mkconfig -o /boot/grub/grub.cfg
exit
reboot

Cheers...

1
  • When I ran lsblk, I noticed that my partition was not mounted some reason.... following this fixed it! Thanks!
    – Nick
    Jul 26 '15 at 1:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.