2

Have a new Dell machine with a fresh install of CentOS 6.4.

I have a headset hooked up via USB, but no sound.

I'm not sure CentOS is recognizing my sound card -- or maybe it's not recognizing the USB headset?

Card and headset are listed in /proc/asound/cards:

[root@Azaz07 asound]# cat cards
0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xf7d10000 irq 30

1 [USB            ]: USB-Audio - Plantronics .Audio 478 USB
                      Plantronics Plantronics .Audio 478 USB at usb-0000:00:1a.0-1.3, full speed

I successfully followed the steps here to install kmod-alsa, but it didn't seem to make a difference.

I also tried to install "Sound and Video" as a group package, as detailed here, but got an error:

[root@Azaz07 ~]# yum groupinstall "Sound and Video"
Loaded plugins: fastestmirror, refresh-packagekit, security
Loading mirror speeds from cached hostfile
 * base: mirrors.sonic.net
 * elrepo: elrepo.org
 * extras: centos.mirror.freedomvoice.com
 * rpmforge: mirror.hmc.edu
 * updates: mirror.pac-12.org
Setting up Group Process
Checking for new repos for mirrors
Warning: Group Sound and Video does not exist.
No packages in any requested group available to install or update

What should I check / troubleshoot from here to get my USB headset working?

2
  • I'd boot a newer livecd (OpenSUSE, Fedora, ....), get the lspci output and maybe the dmesg of that machine and paste it somewhere. Since the machine is new, chances are a more recent kernel like ones included with the distributions above will work.
    – schaiba
    Nov 29, 2013 at 21:07
  • What does the sound preferences look like? See my A for an example.
    – slm
    Nov 29, 2013 at 21:18

1 Answer 1

3

lsusb

First thing to try is make sure that the device shows up when plugged in.

Example

I have a Logitech headset.

$ lsusb
Bus 002 Device 006: ID 046d:0a01 Logitech, Inc. USB Headset
Bus 002 Device 005: ID 046d:c521 Logitech, Inc. Cordless Mouse Receiver
Bus 002 Device 004: ID 17ef:1003 Lenovo Integrated Smart Card Reader
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

You can find out more about it by enabling the -v switch to lsusb.

Example

$ lsusb -v | less
Bus 002 Device 006: ID 046d:0a01 Logitech, Inc. USB Headset
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               1.10
  bDeviceClass            0 (Defined at Interface level)
  bDeviceSubClass         0 
  bDeviceProtocol         0 
  bMaxPacketSize0         8
  idVendor           0x046d Logitech, Inc.
  idProduct          0x0a01 USB Headset
  bcdDevice           10.13
  iManufacturer           1 
  iProduct                2 
  iSerial                 0 
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength          318
    bNumInterfaces          3
    bConfigurationValue     1
    iConfiguration          0 
...

dmesg

Next check that the hardware shows up as being detected correctly via dmesg output.

$ dmesg
...
[237717.191322] usb 2-1.1: USB disconnect, address 3
[237717.387495] usb 2-1.1: new low speed USB device using ehci_hcd and address 5
[237717.482484] usb 2-1.1: New USB device found, idVendor=046d, idProduct=c521
[237717.482487] usb 2-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[237717.482489] usb 2-1.1: Product: USB Receiver
[237717.482491] usb 2-1.1: Manufacturer: Logitech
[237717.488818] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.0/input/input10
[237717.488955] generic-usb 0003:046D:C521.0003: input,hidraw0: USB HID v1.11 Mouse [Logitech USB Receiver] on usb-0000:00:1d.0-1.1/input0
[237717.495771] input: Logitech USB Receiver as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.1/input/input11
[237717.495984] generic-usb 0003:046D:C521.0004: input,hiddev96,hidraw1: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:1d.0-1.1/input1
[240126.944155] usb 2-1.2: new full speed USB device using ehci_hcd and address 6
[240127.034731] usb 2-1.2: New USB device found, idVendor=046d, idProduct=0a01
[240127.034735] usb 2-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[240127.034738] usb 2-1.2: Product: Logitech USB Headset
[240127.034740] usb 2-1.2: Manufacturer: Logitech
[240127.232622] usbcore: registered new interface driver snd-usb-audio

Sound preferences

Under the speaker applet in GNOME you can access the sound preferences for your system. Make sure that the speakers are selected as the active output device.

                    applet   prefs menu

          sound prefs dialog

4
  • Yeah, dmesg seems to have some strange output. usb 1-1.3: new full speed USB device number 5 using ehci_hcd usb 1-1.3: New USB device found... usb 1-1.3: Product: Plantronics .Audio 478 USB usb 1-1.3: configuration #1 chosen from 1 choice input: Plantronics Plantronics .Audio 478 USB as /devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.3/1-1.3:1.3/input/input7 generic-usb 0003:047F:C011.0004: input,hiddev96,hidraw2: USB HID v1.00 Device [Plantronics Plantronics .Audio 478 USB] on usb-0000:00:1a.0-1.3/input3 ALSA urb.c:831: cannot submit datapipe for urb 0, error -28: not enough bandwidth
    – some1
    Nov 29, 2013 at 21:20
  • You got it with your last update. The output apparently doesn't automatically switch over to the USB headset in sound preferences, once I switched it manually it did work. Is there a way to access those preferences via command line though?
    – some1
    Nov 29, 2013 at 21:23
  • @some1 - gets me every time too 8-)
    – slm
    Nov 29, 2013 at 21:26
  • 1
    You can use the commands to list the sinks: pacmd "list-sinks". Once identified you can use a command like this to set the output: pacmd "set-default-sink alsa_output.usb-Logitech_Logitech_USB_Headset-00-Headset.analog-stereo".
    – slm
    Nov 29, 2013 at 21:39

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .