2

I'm trying to compile and install binutils+GCC for my machine on my own. I have compiled lastest binutils sources without getting any error, but installation seems to have some problems with gas documentation.

Here is my installation log:

make[2]: Leaving directory '/src/binutils-2.23.51-1/build/etc'
make[2]: Entering directory '/src/binutils-2.23.51-1/build/gas'
Making install in doc
make[3]: Entering directory '/src/binutils-2.23.51-1/build/gas/doc'
make[4]: Entering directory '/src/binutils-2.23.51-1/build/gas/doc'
make[4]: Nothing to be done for 'install-exec-am'.
../../../gas/doc/c-arc.texi:223: command @bullet not accepting argument in brace should not be on @table line
../../../gas/doc/c-arm.texi:393: command @bullet not accepting argument in brace should not be on @table line
../../../gas/doc/c-arm.texi:394: warning: @item missing argument
...
../../../gas/doc/c-cr16.texi:65: warning: @item missing argument
../../../gas/doc/c-tic54x.texi:113: @code expected brace
...
../../../gas/doc/c-i386.texi:979: warning: node prev `i386-Bugs' in menu `i386-Arch' and in sectioning `i386-16bit' differ
...
../../../gas/doc/c-xtensa.texi:9: warning: node `Z80-Dependent' is next for `Xtensa-Dependent' in menu but not in sectioning
Makefile:397: recipe for target 'as.info' failed
make[4]: *** [as.info] Error 1
make[4]: Leaving directory '/src/binutils-2.23.51-1/build/gas/doc'
Makefile:592: recipe for target 'install-am' failed
make[3]: *** [install-am] Error 2
make[3]: Leaving directory '/src/binutils-2.23.51-1/build/gas/doc'
Makefile:2182: recipe for target 'install-recursive' failed
make[2]: *** [install-recursive] Error 1
make[2]: Leaving directory '/src/binutils-2.23.51-1/build/gas'
Makefile:4761: recipe for target 'install-gas' failed
make[1]: *** [install-gas] Error 2
make[1]: Leaving directory '/src/binutils-2.23.51-1/build'
Makefile:2141: recipe for target 'install' failed
make: *** [install] Error 2

The output is very large and some of the warnings are repeating (they just occur on different lines). It looks like the problem is caused by as.info file, and I guess I'm using old version of some tool for .texi files. I don't know what to do now. Does anybody have any idea what can I do for running the installation successfully?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.