2

I am using LibreOffce 4.1.2.3 in Linux Mint 16 Petra.

When I try to run a spell check, no checking occurs, and I immediately get this response:

spell check error

It seems to indicate my language and location aren't set, so I have tried to ensure my language is set to Canadian English:

setting language

I've also double checked in the preferences:

language preferences

Nothing I have done has had any effect.

How do I get the spell checker to work?

0

since a while the spell check is a plugin witch you have to install on you own. http://extensions.libreoffice.org/extension-center?getCategories=Dictionary

0

This problem still exists in 2015 in Linux Mint 17.1. To remedy the situation, you will need to install hunspell or myspell modules for your preferred language. E.g.

sudo apt-get install myspell-en-us

Then after doing this, comes the KEY step.

Open LibreOffice and go to Tools → Options → Language Settings → Writing Aids and select the spell check modules appearing there and Edit them and change the language to your preferred language which has a spell-check module installed.

Also, set your preferred language in Tools → Options → Language Settings → Languages. Restart your libreoffice for the settings to take effect.

In both these setting you will see that the languages which have the spell-check modules installed will have a little spell-check icon besides their name, as shown in the screen-shot.

Screen-shot for first setting enter image description here

Screen-shot for second setting

enter image description here

-1

Other Option is you can Copy and Paste all the items in Tomboy Notes and then you can change all the spelling errors.

  • This isn't really helpful. The question is about LibreOffice and not asking about external tools. – BrainStone Mar 31 '16 at 9:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.