I did something wrong

On my CentOS 5.9, I did the following:

cd /usr/local/directadmin/custombuild
./build rewrite_confs

But now I get an error restarting httpd:

[root@1332 conf]# service httpd restart
Stopping httpd:                                            [FAILED]
Starting httpd: Syntax error on line 213 of /usr/local/directadmin/data/users/admin/httpd.conf:
Unknown DAV provider: svn

@line 213, there is something like:

<Location />
    DAV svn
    SVNPath /var/svn/
    AuthType Basic
    AuthName "Dytech Solutions Subversion repository"
    AuthUserFile /etc/svn-auth-file
    Require valid-user

My guess is that my DirectAdmin is automatically writing them locale httpd.conf files. And I messed up the SVN repositories somehow...

I'm also guessing that it has to do something with an alternative apache config due to autobuild so the module isn't loaded normally.

I found this link

Where its states that:

First, your httpd.conf needs to load the mod_dav_svn module. If you pass --enable-mod-activation to Subversion's configure, 'make install' target should automatically add this line for you. In any case, if Apache HTTPD gives you an error like "Unknown DAV provider: svn", then you may want to verify that this line exists in your httpd.conf:

     LoadModule dav_svn_module     modules/mod_dav_svn.so

But I'm afraid to break even more stuff

Please help


Is this line commented out in your httpd.conf like so?


#LoadModule dav_svn_module modules/mod_dav_svn.so


LoadModule dav_svn_module modules/mod_dav_svn.so

If it is, uncomment it and restart apache. Hope you've already fixed it.

  • 1
    I had a similar problem and with Ubuntu 20.04 I had to (1) provide the directive in file /etc/apache2/mods-available/dav_svn.load and (2) make sure I had the necessary symbolic links (ln -s) in the directory etc/apache2/mods-enabled to the following files in /etc/apache2/mods-available: dav_svn.conf, dav_svn.load, dav_fs.conf, dav_fs.load, and dav.load. See askubuntu.com/questions/1299877/… Dec 15 '20 at 0:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.