6

I am configuring colors in Mutt, but I think my problem is general to linux terminal.

For the 16 predefined colors (such as red) I can make it bold, by specifying brightred

However, when using 256 colors (such as color208), there is no such color as brightcolor208. I have following color theme in mutt:

color index color208 color236 ~T

How can I make the color208 bold (bright) ?

  • 1
    I didn't think there was a bold 208. There is just another color value (like 220) that appears to a bolder/brighter version of the first... See the output of this script for the 256 colour values. – jasonwryan Nov 27 '13 at 23:03
  • my understanding is, bold is the same color, just the font is thicker (bold). – Martin Vegter Nov 28 '13 at 12:51
  • 2
    This depends entirely on how the terminal emulator renders bold. Even physical terminals dealt with bold in different ways (intensity and/or font changes). – Alexios Dec 17 '13 at 22:37
5

"Boldness" is set separately from "foreground color", but it is not supported by Mutt. All you can do in Mutt is select a foreground and background color, no boldness.

In other cases, where it is possible to output arbitrary ANSI escape sequences, you would set a "bold color 208" as follows (you can execute that in any terminal that allows bold text to see the effect, Gnome Terminal works fine if you have it configured to display bold text):

echo this is NORMAL
echo '\e[1m' this is BOLD '\e[0m'
echo '\e[1;38;5;208m' this is BOLD 208 '\e[0m'
echo '\e[38;5;208m' this is NORMAL 208 '\e[0m'

(The SGR parameter "1" will turn on bold. You send it with <Esc>[1m, and you can of course combine it with others, e.g. <Esc>[1;5m or as in the above example, where 38;5;x selects a color from the XTerm 256-color space.)

0

Your terminal must support 256-colors and have appropriate TERM environment variable set. You likely do not have 256-color support enabled.

For xterm:

export TERM="xterm-256color"

For urxvt:

export TERM="urxvt-256color"

For tmux/screen:

export TERM="screen-256color"

I would place it in ~/.bashrc, ~/.bash_profile or ~/.profile depending on situation.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.