I have RHEL 5.6 (32 bit OS) in my system. I have firefox (17.0.10) installed in my system. I tried to upgrade the firefox to the latest version.

First I did, yum update firefox and got no packages marked for update.

So, I did the following commands.

wget Uvh http://download.fedoraproject.org/pub/epel/6/i386/epel-release-6-8.noarch.rpm

rpm -Uvh epel-release-6-8.noarch.rpm

However, when I ran the above commands I got the failed dependencies error as below.

error: Failed dependencies:
        redhat-release >= 6 is needed by epel-release-6-8.noarch
        rpmlib(FileDigests) <= 4.6.0-1 is needed by epel-release-6-8.noarch
        rpmlib(PayloadIsXz) <= 5.2-1 is needed by epel-release-6-8.noarch

When I run the below command, I get the latest version is already installed in my system.

yum --enablerepo=remi list firefox

The above command gives me only version 17.0.10. I am trying to install the latest version in my RHEL system.

  • redhat-release >= 6 is needed seems to be a big clue. 5.6 ! >= 6 – goldilocks Nov 25 '13 at 16:55
  • hmm, yeah. I tried to upgrade using the packages for 5 version and when I did yum update firefox, it is saying me I have got the latest version already installed. – Ramesh Nov 25 '13 at 17:05
  • So, just to know, is 17.0.1 the maximum version of firefox that I can install in RHEL 5.6 system? I uninstalled the firefox and tried to install it without the package repository. I was getting the error message as "XPCOMGlueLoad error for file /opt/firefox/libxul.so/" – Ramesh Nov 25 '13 at 17:07

You cannot run the later versions of Firefox on CentOS 5.x. See here:

Lower level libraries that Firefox depends on aren't being kept up to later enough versions that the newer versions of Firefox are being compiled against. This is typically the case with long term releases.

Firefox ESRs

Firefox puts out what they call ESRs (Extended Service Releases) which typically have a wider target audience of distributions that they support. ESR 17 was the last to work on CentOS 5.x so I wouldn't expect to go much further than this one.

What is Mozilla Firefox ESR?

Mozilla will offer an Extended Support Release (ESR) based on an official release of Firefox for desktop for use by organizations including schools, universities, businesses and others who need extended support for mass deployments. You can read more about the plan here.

Version 24 of Firefox will become ESR 24, and this version definitely will not run on CentOS 5.x (according to the testing I've done on 5.9). So you're essentially stuck on this older version until Mozilla releases a newer version built with the older libraries support.

ss of ESR roadmap

You could always try and compile it yourself on CentOS 5.x targeting this older version of the library.

Totally dead?

I've done this before but would not recommend running this way. You can "sometimes" find prebuilt versions of Firefox and it's corresponding packages (XUL - aka. libxul) from other releases of Fedora. These .so libraries can "sometimes" be unpackaged on CentOS 5.x into a separate directory and then brought into the mix when invoking Firefox.

sample error

./firefox: symbol lookup error: ./libstdc++.so.6: undefined symbol: _ZNSt7num_getIcSt19istreambuf_iteratorIcSt11char_traitsIcEEE2idE, version GLIBCXX_3.4

This has the effect of allowing Firefox to run with the newer libraries it wants while still leaving your CentOS 5.x system's central libraries intact for the rest of the system.

This in general will work, but I've noticed that Firefox doesn't perform as reliably when operated in this state, so I would recommend not bothering with this approach!

  • I uninstalled the package supplied firefox version. And then I downloaded the latest version of firefox (25.0.1) from the mozilla site. I followed the instructions as mentioned in ths site. However, I was getting the error as {"XPCOMGlueLoad error for file /opt/firefox/libxul.so: libgio-2.0.so.0: cannot open shared object file: No such file or directory Couldn't load XPCOM."} – Ramesh Nov 25 '13 at 17:28
  • So, as per the figure, if I try to install FF 23, I should be able to do it in my system. Am I right in my understanding – Ramesh Nov 25 '13 at 17:29
  • 1
    @Ramesh - yes you won't be able to use those versions on CentOS, is kind of the point I'm making with this answer. Firefox typically needs a secondary package to work called XUL (libxul.so). This package is often rev'd at the same levels as firefox. So there's usually a 17 XUL to go along with 17 FF. XUL is usually where the dependency issues show up. – slm Nov 25 '13 at 17:30
  • Thanks a lot for the detailed explanation. Can you please let me know if these statements are right? I can not install FF versions greater than 17 unless and until the later versions (like 18 and above) are provided by the package manager. If I need to install FF 18 or above, I might be needing the corresponding 18XUL and above which is not provided by the current OS. So, I will not be able to install the latest versions of FF. – Ramesh Nov 25 '13 at 17:35
  • @Ramesh - your above comments are correct! – slm Nov 25 '13 at 17:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.