I have a newly installed Fedora 19 on an Intel NUC computer. During installation, I selected the "reclaim all space" option and took the default partitioning. The install created an EFI boot partition, but the BIOS on the computer does not seem to recognize it. I can boot Fedora Live from a USB stick and mount the partitions without issue.

If the UEFI boot and Legacy boot options are both selected, the BIOS displays

Reboot and Select proper Boot device
or Insert Boot Media in selected Boot device and press a key.

If either of the options are unchecked:

A bootable device has not been detected.
Please refer to the Product Guide at http://support.interl.com/support/motherboards/desktop

I did not find any helpful info at the URL above...

Here is the partition table:

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048          411647   200.0 MiB   EF00  EFI System Partition
   2          411648         1435647   500.0 MiB   0700  
   3         1435648       234440703   111.1 GiB   8E00 

And the details on partition 1:

Partition number (1-3): 1
Partition GUID code: C12A7328-F81F-11D2-BA4B-00A0C93EC93B (EFI System)
Partition unique GUID: C81832BE-6B66-474C-99B3-8C4DF9654B93
First sector: 2048 (at 1024.0 KiB)
Last sector: 411647 (at 201.0 MiB)
Partition size: 409600 sectors (200.0 MiB)
Attribute flags: 0000000000000000
Partition name: 'EFI System Partition'

I've been unsuccessful in finding details that match this particular scenario

Here is the output from efibootmgr after booting from the USB stick.

# efibootmgr
BootCurrent: 0004
Timeout: 1 seconds
BootOrder: 0001,0002,0003,0004,0000
Boot0000* Fedora
Boot0001* SATA : PORT 0 : Crucial_CT120M500SSD3 : PART 0 : Boot Drive
Boot0002* USB : Generic SD/MMC/MS/xD 1.07
Boot0003* USB : Generic MicroSD/M2 1.08 : PART 1 : Boot Drive
Boot0004* UEFI : USB : Generic MicroSD/M2 1.08 : PART 0 : OS Bootloader

Ideally, I'd like to be able to boot directly from the SATA drive, but at this point, I'd also be open to a solution that has a multi-stage boot using a USB stick -- as long as the root partition is on the SATA drive.

1 Answer 1


I resolved this by booting the Fedora 19 Live CD with UEFI disabled (i.e., only Legacy Boot enabled), and reinstalling F19, which created an MBR configuration. I don't have UEFI, but I do have a bootable install.

  • This also applied to a NUC installation of Fedora 22. @TomG saves the day! Jul 16, 2015 at 18:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.