Is it possible to install the rts5139 driver in Fedora 19 3.11.8-200.fc19.i686.PAE kernel ?

I have a Lenovo G570 laptop, on which I run Fedora 19 (3.11.8-200.fc19.i686.PAE kernel) on one hard disk, and used to run Ubuntu 12.04 on an external. The Fedora one I use for work, while I use the Ubuntu one for programming my Raspberry Pi.

On 12.04, the SD card reader did not work. BUT, I have recently installed 13.10 over 12.04, and the card reader works - here is the lshw output (off of 13.10):

id:                scsi:2
physical id:       4
bus info:          usb@1:1.4
logical name:      scsi7
capabilities:      emulated scsi-host
configuration:     driver   =   rts5139

and the lsusb output (off of Fedora 19 - lshw does not detect it, even with an SD card in it):

Bus 001 Device 003: ID 0bda:0139 Realtek Semiconductor Corp. RTS5139 Card Reader Controller
Couldn't open device, some information will be missing
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               2.00
  bDeviceClass          255 Vendor Specific Class
  bDeviceSubClass       255 Vendor Specific Subclass
  bDeviceProtocol       255 Vendor Specific Protocol
  bMaxPacketSize0        64
  idVendor           0x0bda Realtek Semiconductor Corp.
  idProduct          0x0139 RTS5139 Card Reader Controller
  bcdDevice           39.60
  iManufacturer           1 
  iProduct                2 
  iSerial                 3 
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength           39
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          4 
    bmAttributes         0xa0
      (Bus Powered)
      Remote Wakeup
    MaxPower              500mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           3
      bInterfaceClass       255 Vendor Specific Class
      bInterfaceSubClass      6 
      bInterfaceProtocol     80 
      iInterface              5 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x01  EP 1 OUT
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x82  EP 2 IN
        bmAttributes            2
          Transfer Type            Bulk
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0200  1x 512 bytes
        bInterval               0
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x83  EP 3 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0003  1x 3 bytes
        bInterval              10

So is there a way I can get the rts5139 driver for the card reader, or use alien or something to convert the Ubuntu driver for use on my Fedora 19 system?

lsmod or usbview does not find anything either.


Confirming the kernel module

Check what drivers are currently loaded into your Kernel under Fedora.


$ lsmod | head -10
Module                  Size  Used by
iwlagn                209751  0 
iwlcore               195714  1 iwlagn
cpufreq_powersave       1154  0 
tcp_lp                  2111  0 
aesni_intel            12131  1 
cryptd                  7111  1 aesni_intel
aes_x86_64              7758  1 aesni_intel
aes_generic            26908  2 aesni_intel,aes_x86_64
fuse                   61966  3 

You can also grep this output looking for this driver:

$ lsmod | grep rts5139

Loading the module

If that doesn't return any matches then you'll need to load that driver:

$ sudo modprobe rts5139

Check to see if that resolves your issue. If it does then you can make this module load all the time by adding it to your system's list of modules to load during boots.

Loading the module permanently

$ sudo echo rts5139 >> /etc/modules

You could also make it its own config file like so:

$ sudo tee /etc/modules-load.d/sdcardreader.conf <<EOF
#Load SD Reader RTS5129, which uses driver RTS5139

That will create the file that will load the module from reboot to reboot.

Modules missing?

I also came across this thread titled: Fedora 19 SD Card not recognized, which is exactly the same issue you're experiencing.

According to that thread updating your Linux kernel, sounds like it will get you closer to a working module.


The problem may be in kernel. I have problem with kernels 3.10.(3-6) in mounting USB sticks. Version 3.10.2 was OK, 3.10.7 (I've updated today) is OK either. So try to update you distro and check if problem is remain.


  • 1
    Thank you for answering! Nothing from lsmod. Looked at your link and found lxr.free-electrons.com/source/drivers/staging/rts5139 - but how do I install the driver? [wilf@comp ~]$ sudo modprobe rts5139 [sudo] password for wilf: modprobe: FATAL: Module rts5139 not found. – Wilf Nov 23 '13 at 19:11
  • @wilf - see updates. – slm Nov 23 '13 at 19:29
  • 1
    Works nows! I ran sudo yum install kmod-staging, and it works! I have to use the 3.11.8-200.fc19.i686 kernel though, but I shall post another question on it (Or just use 64bit when I get up to Fedora 20 ). – Wilf Nov 23 '13 at 20:09
  • 1
    it seems that module now has name rtsx_usb, 3.16.2-201.fc20.x86_64 – edbond Sep 21 '14 at 6:06
  • The answer of edbond shed light to me, thanks! I am with Ubuntu 16.04 LTS. – WesternGun Sep 13 '16 at 13:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.