4

I purchased a Wacom Intuos graphics pad recently (specifically, Create Pen & Touch Tablet, which I think is the rebranding of the Intuos 4), and I am trying to configure it on my Linux Mint 15 system.

I followed these instructions regarding the configuration on The Linux Wacom Project's wiki

Here are some pertinent specs about my computer w.r.t. the installation:

$ uname -r
3.8.0-33-generic

/etc/X11/xorg.conf.d $ ls
10-evdev.conf             50-synaptics.conf  51-synaptics-quirks.conf
11-evdev-quirks.conf      50-vmmouse.conf
11-evdev-trackpoint.conf  50-wacom.conf

(Note that the wacom configuration is there.)

/etc/X11/xorg.conf.d $ X -version

X.Org X Server 1.13.3
Release Date: 2013-03-07
X Protocol Version 11, Revision 0

When I ran all of the configurations and make commands it all (eventually) worked out OK as per feedback in those commands. But still nothing... the device cannot be found when I type a command like:

/etc/X11/xorg.conf.d $ xinput list
⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ Logitech USB Optical Mouse                id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Logitech USB Keyboard                     id=9    [slave  keyboard (3)]
    ↳ Logitech USB Keyboard                     id=10   [slave  keyboard (3)]

It is not recognizing the wacom tablet at all. I have looked at the wacom config files, and they all seem to be correct (as best as I can tell). I am using the "hotplugging" method, as recommended (note the directory xorg.conf.d). I'm at a loss what to try next.

I know the problem is configuration, because we also have a Mac at home, and I can get it to work on the Mac. I've used GIMP and similar drawing applications with the tablet on it and it works quite nicely.

I should also mention: when I plug it in, the lights turn on showing it is getting power, and when I click on the buttons, they work, but the tablet pad itself will not work at all... with the pen or by touch.

  • 1
    Hi Mike, what does lsusb -v | grep -i wacom output? Have you plugged it into a USB3 port? If so try a USB2 port, I've sometimes had problems with USB devices being recognised in USB3. AFAIK, the drivers are in the kernel now, you don't need to do anything other than plug in and configure. Have you tried the tablet in another computer (sure it's working)? – Ash Nov 23 '13 at 6:53
  • Hi Ash, thanks! lsusb -v | grep -i wacom yields nothing to stdout. However, to stderr I see multiple Couldn't open device, some information will be missing. In fact, it had this error for every device, including ones that I know work (e.g., mouse & keyboard). But there was nothing mentioning wacom. How do I know if it is USB2 or USB3? What's the command to check? I have tried the tablet in a Mac that we have and it worked fine, but no other Linux (this is the only Linux we have). Thanks! – Mike Williamson Nov 23 '13 at 8:30
  • The "couldn't open device" stuff is just attempting to output details from the other devices that need sudo permission to access (no need to worry). USB3 ports are usually blue on the inside (just unplug and have a look). Otherwise, look at your motherboard or case specs, depending on where you plugged it in. – Ash Nov 23 '13 at 9:47
  • Other things to try in the hunt for clues: lsmod | grep wacom? That will tell you if the wacom kernel module has at least been loaded. dmesg | grep wacom should let you know if there are any errors loading the driver. – Ash Nov 23 '13 at 9:48
  • Hi @Ash , thanks for the advice! I'm at work now but will check tonight. I have sudo access, so I can just do lsusb with higher permissions. I'll also try lsmod and dmesg and update with their feedback. – Mike Williamson Nov 27 '13 at 18:24
1

I just got one of these for my daughter and had to get it going. It seems Wacom changed the USB IDs as part of the rebrand, so the latest drivers are needed. I was using Xubuntu 12.10, but hopefully the process is similar for all Ubuntu downstreams.

These are the steps I used:

After that, the tablet was detected and the driver loaded. Once the tablet is plugged in, if you try the lsmod | grep wacom command, it should show an entry.

Some other dependencies like build-essential were given in other guides I found; they may have already been installed on the machine I was using, so I'm not sure if there are any other dependencies needed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.