0

I somehow changed my prompt (PS1) from [mpatil@localhost ~]$ to bash-4.1$. I also have changed my user mpatil's home directory from /home/mpatil to /home/algo. Now some applications are not working correctly, and I get this error when opening some application:

enter image description here

How can I change the prompt to what it was before, and how can I get the application to work again?

  • I meant we could continue the discussion here. Your command works now, because it doesn't output anything: touch is not supposed to print anything when it created the file succesfully. Does the program about which you have the screenshot on your question work now? – Risto Salminen Nov 21 '13 at 11:25
  • What does your prompt look now? – Risto Salminen Nov 21 '13 at 11:44
  • it looking [mpatil@localhost ~]$ – ram Nov 21 '13 at 11:48
  • Okay, so everything is now working. Good. – Risto Salminen Nov 21 '13 at 11:51
  • @Risto ya working – ram Nov 21 '13 at 11:51
0

Your problem is due to you renamed your user's (mpatil) home directory to /home/algo. That causes that some applications can't read their configurations, because you don't have the directory /home/mpatil anymore. The problem will be solved, when you rename the directory /home/algo to /home/mpatil. You can do that with the following command: mv /home/algo /home/mpatil.

  • What do you mean by "suggest me"? – Risto Salminen Nov 21 '13 at 11:53
  • sorry for that.i mean I have one doubt can you clarify that – ram Nov 21 '13 at 11:57
  • What should I clarify? – Risto Salminen Nov 21 '13 at 11:58
  • in download folder i have one file that is /home/mpatil/Desktop/Ram/downloads/yoono-desktop-1.8.43.tar.bz2.when i try to install this file am getting error,there is no such file or directory.But when i try to open this file,first folder name is "." then yoono-desktop is there.why like this? – ram Nov 21 '13 at 12:04
  • 1
    ok wait i'will post another question.i hope u will answer – ram Nov 21 '13 at 12:19
0

There are two problems here and I'm not sure they are linked together.

  1. You need to setup your bash prompt if you want it looked like this [mpatil@localhost ~]$. Here is a way to do this : How to setup custom bash prompt

  2. Does the file /home/mpatil/.sqldevelopper exist ? If so, what is written in it ?

  • /home/mpatil/.sqldevelopper ya exist – ram Nov 21 '13 at 9:13
  • how to change bash-4.1$ - [mpatil@localhost ~]$.? previously when i open terminal [mpatil@localhost ~]$ showing.now it showing bash-4.1$.now i cant open application . – ram Nov 21 '13 at 9:15
  • all applications are in /home/mpatil and now am in currently /home/algo. – ram Nov 21 '13 at 9:20
  • @Risto present aam in home/algo directory.how to go to /home/mpatil ? – ram Nov 21 '13 at 9:23
  • only mpatil.... – ram Nov 21 '13 at 9:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.