6

After installing and configuring Thunar Volume Manager for Arch Linux it doesn't mount any USB devices automatically:

$ thunar
thunar-volman: Unsupported USB device type.
thunar-volman: Unsupported USB device type.
thunar-volman: Could not detect the volume corresponding to the device.
thunar-volman: Could not detect the volume corresponding to the device.

(Both messages are printed twice when inserting a single USB drive.)

Polkit seems to be running as expected:

$ loginctl show-session $XDG_SESSION_ID
Id=c1
Timestamp=Tue 2013-11-19 20:54:41 GMT
TimestampMonotonic=33281762
VTNr=7
Display=:0.0
Remote=no
RemoteUser=root
Service=slim
Scope=session-c1.scope
Leader=308
Audit=0
Type=x11
Class=user
Active=yes
State=active
IdleHint=no
IdleSinceHint=0
IdleSinceHintMonotonic=0
Name=username

There are a bunch of random tips in this thread, but at least some of them seem at odds with the wiki: gvfs is mentioned, although the wiki only mentions it as a requirement for browsing remote locations.

Manual mounting works fine:

$ sudo mount /dev/sde1 /media/foo
$ mount | grep sde1
/dev/sde1 on /media/foo type fuseblk (rw,nosuid,nodev,relatime,user_id=0,group_id=0,allow_other,blksize=4096)
5

Turns out you have to install gvfs and polkit-gnome to make this work. After logging out and in again Thunar supports mounting USB devices.

  • Archlinux here, same error messages. I have those 2 packages installed, but still does not work (sometimes it mounts it, sometimes it doesn't) – tokland Sep 17 '14 at 7:07
  • 'polkit-gnome' is called 'policykit-1-gnome' in debian stretch. But was already installed and does not fix the issue for me – Alex Dec 29 '17 at 8:35
  • By default thunar does not mount the devices automatically, that must be configured in Thunar. Of course you must have installed gvfs, polkit-gnome and udisks2. Thunar automount Configuration: Thunar > Preferences > advanced > Volumen Configuration > Automount. – Busindre Aug 23 '18 at 22:26
0

Steps:

  • disable thunar volume management and thunar --daemon
  • sudo apt-get install udevil
  • echo "devmon &" >> .xinitrc
  • open thunar and usb auto-mount

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.