0

From here I downloaded a debian-testing-amd64-netinst.iso and boot.img.gz, then I followed these instructions but the result is an USB dongle that is capable of booting the Debian installer, reading the iso in it, but I got no kernel module, no Ethernet and basically I can't install anything with it because I can't go forward with the installation process or download anything from the internet. I tried to burn the iso directly to a CD, same result.

I don't get how I'm supposed to do this, what is the logic behind this cumbersome solution solution with this iso + boot.img system without kernel modules. I don't even get If I'm doing something wrong or what else is the problem.

In the end I'm interested in installing the current Debian testing, codename "Jessie", possibly via Wi-Fi ( I have a WPA2 PSK network ) but I have Ethernet too, using an USB dongle.

  • If the ISO didn't work when your burnt it to CD/DVD, then the ISO is broken. Testing is sometimes broken. Suggest you install wheezy (stable) instead, then edit sources.list and do an upgrade. – derobert Dec 23 '13 at 15:12
2

You are following instructions posted in 2006:

Posted by sebas on Mon 9 Oct 2006 at 12:49

Makes sense they will be a little out of date :). You can probably make this work using netinstall but it will almost certainly not be worth the effort. Just get a Debian installation ISO, burn it onto a CD or a USB stick and install from there (the instructions are here). Once you're done, configure your network for WiFi.

  • ok, but that is wheezy, not jessie. – user2485710 Nov 18 '13 at 16:42
  • @user2485710 just scroll down the page and choose the tesing instead of stable distribution. There are links to both on the page I posted. – terdon Nov 18 '13 at 16:44
  • you mean something like this repository ? cdimage.debian.org/cdimage/weekly-builds/amd64/iso-cd the first CD alone is enough for a desktop installation ? – user2485710 Nov 18 '13 at 16:49
  • I mean, I need the others or I'm fine with just the first one from start to finish ? – user2485710 Nov 18 '13 at 16:59
  • @user2485710 not sure about that actually. I'm asking for help in Unix & Linux Chat. Come and join us. – terdon Nov 18 '13 at 17:01
0

The procedure of creating a USB install dongle using zcat and then copying the ISO file to the USB drive works fine. I've used this procedure many times. There are a few things to keep in mind though:

  1. The kernel versions MUST match in boot.img.gz and the ISO.
  2. To ensure (1) download the files at the same time and ensure the dates are the same [for the daily build]
  3. Don't use wget unless you really need to --- it's much less confusing to download the files directly from the repo on the website and actually seeing the time/date stamp to ensure (1).
  4. The best install results are achieved via wired ethernet - but wireless is doable if you are using a commonly supported wireless adapter.

The boot.img.gz is only bootstrapping the USB drive. After the USB is bootstrapped, the ISO is "booted". Since the ISO is a "bootable" CD image, the ISO is the actual installer. So, the boot.img.gz is only doing "some" of the work to boot the installer, which is why the kernel versions MUST match. Also, any hardware that is usable with a "burned" install CD, should also be available in the USB installation scenario - because it is exactly the same data that is loaded.

0

The problem of unetbootin being broken is reported on the bug list as being caused by Debian Jessie release not conforming to file naming standards. Joliet standards for file names limit the length to 64 characters. Debian Jessie includes file names that exceed the standard used in unetbootin.

Developer comments in the bug list seem to have evolved to a hate-mail attack on unetbootin instead of addressing the standards violation problem in Debian. Developers need to back down from their turf-war and fix the problem.

For graphical or desktop users of Debian, and other Linux distros, it is important that a graphical tool be provided to make bootable .iso images on USB pen-drives. Use of the text based "dd" is not a viable solution. K3B used to work for this purpose on earlier Debian distributions, but with Jessie that too is broken because it refuses to acknowledge insertion of a USB pen-drive media.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.