1

without not much load on the machine, it suddenly went busy and went unresponsive. it could not respond to keyboard or mouse movement or neither would move to another other tty's. there is some log which may hint about the problem. can someone please help identify the problem?

EDIT: also sometimes my internet just stalls; i cannot see any packets going through when using tcpdump. i have to reconnect again to the wifi network for the packets to start flowing again; but i have noticed these problems after i have recently changed my provider to Sky, Uk and they have provided a router with model number, SR101

sky router settings

region: europe; channel: auto; mode: auto; auth: wpa2-psk (aes)

/var/log/syslog

kernel: [ 7593.778323] ------------[ cut here ]------------
kernel: [ 7593.778352] WARNING: at /build/buildd/linux-3.5.0/drivers/net/wireless/brcm80211/brcmsmac/main.c:7953 brcms_c_wait_for_tx_comp
kernel: [ 7593.778355] Hardware name: Satellite R630
kernel: [ 7593.778357] Modules linked in: pci_stub vboxpci(O) vboxnetadp(O) vboxnetflt(O) vboxdrv(O) bnep rfcomm parport_pc ppdev joydev 
kvm arc4 snd_hda_codec_hdmi snd_hda_codec_realtek brcmsmac mac80211 brcmutil cfg80211 cordic uvcvideo videobuf2_core videodev videobu
snd_hwdep snd_pcm microcode snd_seq_midi snd_rawmidi toshiba_acpi sparse_keymap snd_seq_midi_event wmi toshiba_b
mac_hid snd intel_ips lpc_ich soundcore snd_page_alloc i915 drm_kms_helper psmouse serio_raw mei bcma drm i2c_algo_bit video l
[last unloaded: e1000e]
kernel: [ 7593.778416] Pid: 18560, comm: kworker/u:1 Tainted: G           O 3.5.0-17-generic #28-Ubuntu
kernel: [ 7593.778418] Call Trace:
kernel: [ 7593.778428]  [<ffffffff81051c4f>] warn_slowpath_common+0x7f/0xc0
kernel: [ 7593.778432]  [<ffffffff81051caa>] warn_slowpath_null+0x1a/0x20
kernel: [ 7593.778445]  [<ffffffffa03af709>] brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]
kernel: [ 7593.778453]  [<ffffffffa03a05fb>] brcms_ops_flush+0x3b/0x60 [brcmsmac]
kernel: [ 7593.778473]  [<ffffffffa030282d>] ieee80211_scan_work+0x34d/0x5e0 [mac80211]
kernel: [ 7593.778481]  [<ffffffff81083d3a>] ? finish_task_switch+0x4a/0xf0
kernel: [ 7593.778485]  [<ffffffff8107079a>] process_one_work+0x12a/0x420
kernel: [ 7593.778498]  [<ffffffffa03024e0>] ? ieee80211_run_deferred_scan+0x80/0x80 [mac80211]
kernel: [ 7593.778502]  [<ffffffff8107133e>] worker_thread+0x12e/0x2f0
kernel: [ 7593.778506]  [<ffffffff81071210>] ? manage_workers.isra.26+0x200/0x200
kernel: [ 7593.778510]  [<ffffffff81075e33>] kthread+0x93/0xa0
kernel: [ 7593.778516]  [<ffffffff8168b024>] kernel_thread_helper+0x4/0x10
kernel: [ 7593.778520]  [<ffffffff81075da0>] ? kthread_freezable_should_stop+0x70/0x70
kernel: [ 7593.778523]  [<ffffffff8168b020>] ? gs_change+0x13/0x13
kernel: [ 7593.778526] ---[ end trace 6499cba8e2fb8557 ]---

kernel modules

 pci_stub vboxpci vboxnetadp vboxnetflt vboxdrv parport_pc ppdev bnep rfcomm joydev btusb bluetooth snd_hda_codec_hdmi snd_hda_codec_realtek coretemp kvm_intel kvm arc4 brcmsmac mac80211 brcmutil cfg80211 cordic snd_hda_intel snd_hda_codec snd_hwdep snd_pcm snd_seq_midi uvcvideo videobuf2_core videodev videobuf2_vmalloc snd_rawmidi videobuf2_memops snd_seq_midi_event snd_seq snd_timer snd_seq_device toshiba_acpi sparse_keymap wmi toshiba_bluetooth snd mac_hid microcode i915 psmouse serio_raw lpc_ich bcma drm_kms_helper intel_ips drm soundcore snd_page_alloc lp i2c_algo_bit mei video parport sdhci_pci sdhci

uname

Linux 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

network information from lshw

  *-network
       description: Wireless interface
       physical id: 4
       logical name: wlan0
       serial: b4:74:9f:5b:a0:57
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=brcmsmac driverversion=3.5.0-17-generic firmware=N/A ip=192.168.0.4 link=yes multicast=yes wireless=IEEE 802.11bgn

EDIT: wireless info

~$ sudo lspci -vv -s 02:00.0
02:00.0 Network controller: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller (rev 01)
    ..
    Capabilities: [16c v1] Power Budgeting <?>
    Kernel driver in use: bcma-pci-bridge
    Kernel modules: bcma

log when wifi cannot send anymore packets and wifi needs to be turned off and on

kernel: [ 1791.266956] Pid: 7728, comm: kworker/u:0 Tainted: G           O 3.5.0-17-generic #28-Ubuntu
kernel: [ 1791.266958] Call Trace:
kernel: [ 1791.266968]  [<ffffffff81051c4f>] warn_slowpath_common+0x7f/0xc0
kernel: [ 1791.266971]  [<ffffffff81051caa>] warn_slowpath_null+0x1a/0x20
kernel: [ 1791.266980]  [<ffffffffa03f5709>] brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]
kernel: [ 1791.266986]  [<ffffffffa03e65fb>] brcms_ops_flush+0x3b/0x60 [brcmsmac]
kernel: [ 1791.267006]  [<ffffffffa034882d>] ieee80211_scan_work+0x34d/0x5e0 [mac80211]
kernel: [ 1791.267013]  [<ffffffff81083d3a>] ? finish_task_switch+0x4a/0xf0
kernel: [ 1791.267016]  [<ffffffff8107079a>] process_one_work+0x12a/0x420
kernel: [ 1791.267027]  [<ffffffffa03484e0>] ? ieee80211_run_deferred_scan+0x80/0x80 [mac80211]
kernel: [ 1791.267030]  [<ffffffff8107133e>] worker_thread+0x12e/0x2f0
kernel: [ 1791.267033]  [<ffffffff81071210>] ? manage_workers.isra.26+0x200/0x200
kernel: [ 1791.267037]  [<ffffffff81075e33>] kthread+0x93/0xa0
kernel: [ 1791.267042]  [<ffffffff8168b024>] kernel_thread_helper+0x4/0x10
kernel: [ 1791.267046]  [<ffffffff81075da0>] ? kthread_freezable_should_stop+0x70/0x70
kernel: [ 1791.267049]  [<ffffffff8168b020>] ? gs_change+0x13/0x13
kernel: [ 1791.267050] ---[ end trace 56f847a7c78d0da0 ]---
kernel: [ 2004.872993] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4
kernel: [ 2006.035759] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4
kernel: [ 2006.036162] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4
kernel: [ 2006.546185] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4
kernel: [ 2007.543524] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4
kernel: [ 2008.542929] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4

kernel: [ 2408.822335] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4
kernel: [ 2408.868303] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4
kernel: [ 2408.937553] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4
kernel: [ 2408.953977] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4
kernel: [ 2408.958060] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4
kernel: [ 2408.976166] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4
kernel: [ 2409.264878] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4
kernel: [ 2409.766008] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4
kernel: [ 2409.793456] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4
kernel: [ 2409.807420] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4
kernel: [ 2409.834179] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4
kernel: [ 2409.994049] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4
kernel: [ 2410.062283] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4
kernel: [ 2410.067860] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4
kernel: [ 2410.785801] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4
kernel: [ 2410.837042] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4
kernel: [ 2410.915746] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4
kernel: [ 2411.060400] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4
kernel: [ 2411.063439] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4
NetworkManager[991]: <info> (wlan0): device state change: activated -> unavailable (reason 'none') [100 20 0]
NetworkManager[991]: <info> (wlan0): deactivating device (reason 'none') [0]
kernel: [ 2411.249095] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4
kernel: [ 2411.276068] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4
kernel: [ 2411.276755] ieee80211 phy0: >brcms_c_prec_enq_head: No where to go, prec == 4
NetworkManager[991]: <info> (wlan0): canceled DHCP transaction, DHCP client pid 1768
1

Unless this is a regular occurrence it looks like your system experienced a stack trace where an exception was thrown or it crashed. I would continue to monitor it and try and establish the root cause through some series of steps that you performed leading up to this, but in looking at the output, such as this part:

kernel: [ 7593.778416] Pid: 18560, comm: kworker/u:1 Tainted: G           O 3.5.0-17-generic #28-Ubuntu
kernel: [ 7593.778418] Call Trace:
kernel: [ 7593.778428]  [<ffffffff81051c4f>] warn_slowpath_common+0x7f/0xc0
kernel: [ 7593.778432]  [<ffffffff81051caa>] warn_slowpath_null+0x1a/0x20
kernel: [ 7593.778445]  [<ffffffffa03af709>] brcms_c_wait_for_tx_completion+0x99/0xb0 [brcmsmac]
kernel: [ 7593.778453]  [<ffffffffa03a05fb>] brcms_ops_flush+0x3b/0x60 [brcmsmac]
kernel: [ 7593.778473]  [<ffffffffa030282d>] ieee80211_scan_work+0x34d/0x5e0 [mac80211]
kernel: [ 7593.778481]  [<ffffffff81083d3a>] ? finish_task_switch+0x4a/0xf0

It looks like your wireless driver experienced either a momentary glitch or has a bug within it.

EDIT #1 - diabling Wireless-N?

These messages:

brcms_c_prec_enq_head: No where to go, prec == 4

Method #1

Look to be a common occurrence. See this thread: Index» Kernel & Hardware» brcms_c_prec_enq_head: No where to go, prec == 4, from the ArchLinux forums.

One of the "solutions" was to disable the wireless-N feature either on the access point (AP) or on the driver itself.

Looks like it happens when the Access Point is configured as 802.11n. Try changing the AP to 802.11b/g and see if the problem persists. Stopped crashing here. I have a BCM4313 too...

Method #2

I'd been having a similar issue for over a year with a Intel Wireless-N device. I blogged about it here, title: Debugging an Intermittently Dropping Intel Wireless-N 1000 Network Card on Fedora 14.

You can also disable the wireless-N feature within some drivers as another workaround, especially when you can't disable this feature on the AP.

The iwlagn module can have this feature disabled like so:

$ sudo modprobe iwlagn 11n_disable=1

Or it can be done during bootup:

# /etc/modprobe.d/wireless.conf
options iwlagn 11n_disable=1

This might work for you, or you can find out if you're devices driver has a similar feature.

Method #3

Also take a look at this U&L Q&A titled: How to disable the 2.4Ghz band wireless adapter where I show how to disable the 2.4GHz wireless radio on a similar NIC. This can be adapted to disable the 5GHz radio which is the Wireless-N frequency.

  • hi i think your guess is right. i have added some more information when blips happen. thanks. – rag Nov 18 '13 at 9:22
  • @slm actually that's not a segfault. It's simply a stack trace dumped by the kernel because the driver thinks something went wrong. This particular one was probably the result of this WARN_ON_ONCE statement – Patrick Nov 18 '13 at 12:26
  • @Patrick - thanks for pointing out the difference. – slm Nov 18 '13 at 12:49
  • looks like you are suggesting to disable N; will there not be a fix for the problem? – rag Nov 18 '13 at 15:33
  • @rag - I've been using the driver for Intel 1000-N for ~2.5 years and it's never been fixed. Yours is a different driver but there is a lot of issues with different AP's and NICs with Wireless-N so I wouldn't expect a resolution. This get's you so that your NIC is stable/usable, anything after that is gravy. Part of the problem is with how the Wireless-N specification was rolled out and implemented by manufacturers. It was a total mess where some products in a rush to market wanted that feature listed, but were not implemented to spec. – slm Nov 18 '13 at 16:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.