-1

This question already has an answer here:

That question is'n only about Unix/Linux - but contain something...

So - given: host1 with TeamCity server running on 8111 port; host2 which will be "ssh-proxy" between client and host1.

From host1 opened tunnel:

$ ssh -f -N -R 8081:localhost:8111 user@host2

From host2 I can get access to Teamcity on host1:

$ wget localhost:8081
...
13:48:24 (258.85 MB/s) - `login.html.1' saved [5700/5700]

Now, I'm trying open tunnel with Putty from "client" to host2 with intent get access to TeamCity on host1.

Open session in Putty - connect to host2. Go to Settings > Connection > SSH > Tunnels.

Setting: local port 3000 > host2:8081

Clicked "Apply" and in browser trying open page with localhost:3000 - and get nothing...

Can somebody please give any tips? I make a lot of different changes in Putty settings with tunnels - but can't open TeamCity...

marked as duplicate by slm, Anthon, rahmu, jasonwryan, Patrick Nov 14 '13 at 19:04

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Should be -L 3000:localhost:8081 which in putty should translate to local port 3000 > localhost:8081. Note that you can also get a normal ssh client from cygwin. – Stéphane Chazelas Nov 14 '13 at 14:59
  • Yes, I thougt about it and try - but it doesn't work... But! Solution is set L3032 127.0.0.1:8081 - and now it's work. – setevoy Nov 14 '13 at 15:19

Browse other questions tagged or ask your own question.