0

I opened emacs using emacs -nw. Now, when I press M-v, it opens the view menu of the terminal, instead of passing the command to emacs. Is there a way to prevent this from happening? (I'm running on linux mint)

  • What is xterminal? Do you mean xterm or gnome-terminal or is this another terminal emulator? – terdon Nov 14 '13 at 13:47
  • @terdon I'm not sure how to check what terminal it is exactly, but the command that runs is mate-terminal – elyashiv Nov 14 '13 at 13:54
  • In that case, you are running mate-terminal :). It is a fork of gnome-terminal in case you're interested. – terdon Nov 14 '13 at 14:02
0

Assuming that by M-v you actually mean Alt+M or, in emacspeak, ^M-v, you should be able to send ^M by hitting Esc instead of Alt.

Just replace Alt with Esc for any ^M- commands you want to run.

In the specific case of mate-terminal, you can switch off the shortcuts for the menus:

enter image description here

Then, deselect the "Enable menu access keys (such as Alt+F to open the File menu)" option:

enter image description here

  • I know about the Esc, but the Alt is much more accessible. Is there a way to use it? – elyashiv Nov 14 '13 at 13:55
  • @elyashiv see updated answer. – terdon Nov 14 '13 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.