1

I'm running Debian 6.0.8. I misnamed the original username I wanted, so I made a new user with the proper username. On the gnome log on screen, I see two users of the same name (the login screen displays the users "human" name). I knew the second user was the correct user name so I clicked on it.

Once inside gnome, I went to System > Administration > Users and deleted the misnamed user. However, upon reboot, the old, wrongly-named user was still listed there and I clicked on it without thinking. The user directory was apparently gone because the desktop never loaded its icons and I got several errors about not being able to write to or find certain user directories.

I rebooted to get to the correct user and ran userdel -r <bad_username> and first I got an error that the user's home directory didn't exist. After I created it to see if that would get the command to work, I got the error that the user doesn't exist. So I guess the user doesn't exist unix-wise, but the Gnome login screen still presents that user as an option.

It's annoying because it's the first option, and the actual name displayed is my name, the same as the user with the correct username. So if I don't think about it, I wind up clicking on the wrong username.

How can I prevent Gnome from displaying this non-existent user as a login option?

  • Are you using gdm or gdm3? – jordanm Nov 11 '13 at 21:47
  • I don't know what that is -- I did the stock Debian 6 'desktop' install. How can I find out? – user394 Nov 11 '13 at 21:52
  • Actually a ps shows gdm3 in the process list. – user394 Nov 11 '13 at 21:54
1

Apparently this user was coming from gdm (thanks @jordanm!). I added this stanza to /etc/gdm3/greeter.gconf-defaults:

Exclude=USER_TO_EXCLUDE,bad_username

And now it just works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.