1

I've noticed a strange behavior of my shell on Kubuntu. Auto completion doesn't work well when I try to install new software. It works only for default commands (when I type "apt-get inst" and I press tab, "install" is autocompleted) but doesn't work when I type a portion of name of software I want to install. I've tried to uncomment /etc/bash.bashrc lines for auto completion, but nothing changed. What's wrong?

2
  • Have you run apt-get update at least once?
    – terdon
    Nov 11, 2013 at 15:42
  • Did you try hitting tab a few times? I think it takes about 3 if there are a lot of possibilities.
    – goldilocks
    Nov 11, 2013 at 15:53

2 Answers 2

4

You need to have the package bash-completion installed. The default .bashrc for user accounts will source the provided files. If it is not, you will need the following in your .bashrc:

. /etc/bash_completion
3
  • i've already that package installed
    – giozh
    Nov 11, 2013 at 16:21
  • SOLVED: i've remove and clean old bash-completion and install it again. Now seems it works
    – giozh
    Nov 11, 2013 at 17:08
  • Ok, today i've reboot my system and auto completion doesn't work again... i've solved by install auto-complete-el
    – giozh
    Nov 12, 2013 at 14:21
3

First of all, assure your sudo apt-get update works well and all your sources are ok.

Here they solve by installing auto-complete-el

sudo apt-get install auto-complete-el 

Here they solved because accidentally ~/.bashrc was deleted. You can get a working copy from /etc/skel/.bashrc

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .