1

I am attempting to install a newer version of HPLIP on a CentOS 5 server to all support for a newer printer.

However I have been unable to do this so far. I found there was an updated package on repoforge found here http://pkgs.repoforge.org/hplip/. So I installed repoforge and attempted to install. When I tried using yum to install it simply states the latest version of hplip was already installed. Any ideas why I cannot install the repoforge version of hplip? Or does anyone know of a good way to install the newer hplip?.

I have also tried to auto install .run file from the official site this locks up my ssh session and the .rpm file has dependency issues.

1

There is likely a mismatch in the naming convention being used by repoforge vs. the default convention for this particular package. This is a more often occurrence with Redhat distros than most of us that use them would like to admit.

Your options are to remove the existing hplip, and then manually install the one from repoforge. You'll need to tell yum that you want it to ignore this package going forward, since you're manually forcing it to use a different one than the versioning within yum is indicating.

You can exclude this package within a specific repo's .repo file by adding this line to that file:

exclude=hplip*

I'm not sure of the .repo file's name so you'll need to sleuth a bit and figure out which repo is providing this package:

Example

$ repoquery --info hplip

Name        : hplip
Version     : 3.11.10
Release     : 5.fc14
Architecture: x86_64
Size        : 9245206
Packager    : Fedora Project
Group       : System Environment/Daemons
URL         : http://hplip.sourceforge.net/
Repository  : updates
Summary     : HP Linux Imaging and Printing Project
Description :
The Hewlett-Packard Linux Imaging and Printing Project provides
drivers for HP printers and multi-function peripherals.

Then grep for the package's repo:

$ grep -F '[updates]' /etc/yum.repos.d/*
/etc/yum.repos.d/fedora-updates.repo:[updates]

There are other more succinct ways to do this, but this is off the top of my head.

Temporarily

Also this can be temporarily done via the command line:

$ yum update hplip --disablerepo=updates

But this method can be annoying, since subsequent updates via yum will attempt to update this, so I generally use the exclude method above.

References

  • Got it working. I needed to enable the testing repo in repo forge. I also disabled hplip form base as you stated. above. Thanks for the assistance – dgibbs Nov 12 '13 at 14:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.