2 replaced http://docs.xfce.org/ with https://docs.xfce.org/
source | link
  1. Try running exo-preferred-applications from the terminal(Ctrl+Alt+t ). You should see an option to change your file manager on the 2nd tab named "Utilities".

    http://docs.xfce.org/_media/xfce/exo/exo-preferred-applications-utilities.png

    Change the File Manager option to "Nautilus".

  2. Using xdg-mime, You could also run the following command to determine your current default file manager:

    • xdg-mime query default inode/directory

    • In your case, this should return thunar.desktop as a result.

    • In order to change this, run:

    • xdg-mime default nautilus.desktop inode/directory application

  3. You can edit the file ~/.local/share/applications/mimeapps.list
    • look for the line containing inode/directory=thunar.desktop;
    • change it to read inode/directory=nautilus.desktop;
  1. Try running exo-preferred-applications from the terminal(Ctrl+Alt+t ). You should see an option to change your file manager on the 2nd tab named "Utilities".

    http://docs.xfce.org/_media/xfce/exo/exo-preferred-applications-utilities.png

    Change the File Manager option to "Nautilus".

  2. Using xdg-mime, You could also run the following command to determine your current default file manager:

    • xdg-mime query default inode/directory

    • In your case, this should return thunar.desktop as a result.

    • In order to change this, run:

    • xdg-mime default nautilus.desktop inode/directory application

  3. You can edit the file ~/.local/share/applications/mimeapps.list
    • look for the line containing inode/directory=thunar.desktop;
    • change it to read inode/directory=nautilus.desktop;
  1. Try running exo-preferred-applications from the terminal(Ctrl+Alt+t ). You should see an option to change your file manager on the 2nd tab named "Utilities".

    Change the File Manager option to "Nautilus".

  2. Using xdg-mime, You could also run the following command to determine your current default file manager:

    • xdg-mime query default inode/directory

    • In your case, this should return thunar.desktop as a result.

    • In order to change this, run:

    • xdg-mime default nautilus.desktop inode/directory application

  3. You can edit the file ~/.local/share/applications/mimeapps.list
    • look for the line containing inode/directory=thunar.desktop;
    • change it to read inode/directory=nautilus.desktop;
1
source | link

  1. Try running exo-preferred-applications from the terminal(Ctrl+Alt+t ). You should see an option to change your file manager on the 2nd tab named "Utilities".

    http://docs.xfce.org/_media/xfce/exo/exo-preferred-applications-utilities.png

    Change the File Manager option to "Nautilus".

  2. Using xdg-mime, You could also run the following command to determine your current default file manager:

    • xdg-mime query default inode/directory

    • In your case, this should return thunar.desktop as a result.

    • In order to change this, run:

    • xdg-mime default nautilus.desktop inode/directory application

  3. You can edit the file ~/.local/share/applications/mimeapps.list
    • look for the line containing inode/directory=thunar.desktop;
    • change it to read inode/directory=nautilus.desktop;