2 deleted 41 characters in body
source | link

After two hours of pain I finally managed to get OpenVPN running! This is what I found out.

openvpn@server.service: Failed to reset devices.list: Operation not permitted

Since I'm running it on a Proxmox LXC container I had to put something into /etc/pve/lxc/<ID>.conf on the Proxmox host to create the needed tun device:

lxc.mount.entry = /dev/net/tun dev/net/tun none bind,create=file

After that change a new error occured:

ovpn-server[1693]: daemon() failed or unsupported: Resource temporarily unavailable (errno=11)

This was fixed by commenting out in /lib/systemd/system/openvpn@.service:

#LimitNPROC=10

Helpful resources:

If you need clarification please comment.

After two hours of pain I finally managed to get OpenVPN running! This is what I found out.

openvpn@server.service: Failed to reset devices.list: Operation not permitted

Since I'm running it on a Proxmox LXC container I had to put something into /etc/pve/lxc/<ID>.conf on the Proxmox host to create the needed tun device:

lxc.mount.entry = /dev/net/tun dev/net/tun none bind,create=file

After that change a new error occured:

ovpn-server[1693]: daemon() failed or unsupported: Resource temporarily unavailable (errno=11)

This was fixed by commenting out in /lib/systemd/system/openvpn@.service:

#LimitNPROC=10

Helpful resources:

If you need clarification please comment.

After two hours of pain I finally managed to get OpenVPN running! This is what I found out.

openvpn@server.service: Failed to reset devices.list: Operation not permitted

Since I'm running it on a Proxmox LXC container I had to put something into /etc/pve/lxc/<ID>.conf on the Proxmox host to create the needed tun device:

lxc.mount.entry = /dev/net/tun dev/net/tun none bind,create=file

After that change a new error occured:

ovpn-server[1693]: daemon() failed or unsupported: Resource temporarily unavailable (errno=11)

This was fixed by commenting out in /lib/systemd/system/openvpn@.service:

#LimitNPROC=10

Helpful resources:

1
source | link

After two hours of pain I finally managed to get OpenVPN running! This is what I found out.

openvpn@server.service: Failed to reset devices.list: Operation not permitted

Since I'm running it on a Proxmox LXC container I had to put something into /etc/pve/lxc/<ID>.conf on the Proxmox host to create the needed tun device:

lxc.mount.entry = /dev/net/tun dev/net/tun none bind,create=file

After that change a new error occured:

ovpn-server[1693]: daemon() failed or unsupported: Resource temporarily unavailable (errno=11)

This was fixed by commenting out in /lib/systemd/system/openvpn@.service:

#LimitNPROC=10

Helpful resources:

If you need clarification please comment.