3 added 121 characters in body
source | link

I tried:

cpupower frequency-set -g performance

But still, the frequency is only at 1200 MHz.

It only goes up if I put a load on the machine, but it should be running at always 100% cpu frequency.

Using SLES 12.2.

SERVER:~ # cat /proc/cmdline
BOOT_IMAGE=/vmlinuz-4.4.121-92.80-default root=/dev/mapper/vg00-lv_root splash=silent quiet showopts console=tty0 console=ttyS0,9600 elevator=noop transparent_hugepage=never crashkernel=768M numa_balancing=disable intel_idle.max_cstate=1
SERVER:~ #

What am I missing?

If it is maybe some UEFI settings, is there any command, ex.: asu64 to update the UEFI setting without a reboot?

Machine is a "x3850 X6", CPU is: " Xeon(R) CPU E7-8880 v4 @ 2.20GHz".

FoundUpdate#1: found something, maybe:

SERVER:~ # systemctl start cpupower
Failed to start cpupower.service: Unit cpupower.service failed to load: No such file or directory.
SERVER:~ # echo $?
5
SERVER:~ #
SERVER:~ # systemctl status cpupower
? cpupower.service
   Loaded: not-found (Reason: No such file or directory)
   Active: inactive (dead)
SERVER:~ #

Update for the update#1: I followed the https://www.suse.com/support/kb/doc/?id=7021316 but didn't helped.

Update#2: tried to set the freq but didn't helped.

SERVER:~ # lscpu | awk '/Model name:/{print $NF}'
2.20GHz
SERVER:~ # cpupower frequency-set -u 2.20GHz
...
SERVER:~ # cpupower frequency-set -u 2.2GHz
...
SERVER:~ # lscpu |egrep  "CPU MHz|CPU(s)" | awk '{print $3}' | awk -F "." '{print $1}'
1200
SERVER:~ #

I tried:

cpupower frequency-set -g performance

But still, the frequency is only at 1200 MHz.

It only goes up if I put a load on the machine, but it should be running at always 100% cpu frequency.

Using SLES 12.2.

SERVER:~ # cat /proc/cmdline
BOOT_IMAGE=/vmlinuz-4.4.121-92.80-default root=/dev/mapper/vg00-lv_root splash=silent quiet showopts console=tty0 console=ttyS0,9600 elevator=noop transparent_hugepage=never crashkernel=768M numa_balancing=disable intel_idle.max_cstate=1
SERVER:~ #

What am I missing?

If it is maybe some UEFI settings, is there any command, ex.: asu64 to update the UEFI setting without a reboot?

Machine is a "x3850 X6", CPU is: " Xeon(R) CPU E7-8880 v4 @ 2.20GHz".

Found something, maybe:

SERVER:~ # systemctl start cpupower
Failed to start cpupower.service: Unit cpupower.service failed to load: No such file or directory.
SERVER:~ # echo $?
5
SERVER:~ #
SERVER:~ # systemctl status cpupower
? cpupower.service
   Loaded: not-found (Reason: No such file or directory)
   Active: inactive (dead)
SERVER:~ #

I tried:

cpupower frequency-set -g performance

But still, the frequency is only at 1200 MHz.

It only goes up if I put a load on the machine, but it should be running at always 100% cpu frequency.

Using SLES 12.2.

SERVER:~ # cat /proc/cmdline
BOOT_IMAGE=/vmlinuz-4.4.121-92.80-default root=/dev/mapper/vg00-lv_root splash=silent quiet showopts console=tty0 console=ttyS0,9600 elevator=noop transparent_hugepage=never crashkernel=768M numa_balancing=disable intel_idle.max_cstate=1
SERVER:~ #

What am I missing?

If it is maybe some UEFI settings, is there any command, ex.: asu64 to update the UEFI setting without a reboot?

Machine is a "x3850 X6", CPU is: " Xeon(R) CPU E7-8880 v4 @ 2.20GHz".

Update#1: found something, maybe:

SERVER:~ # systemctl start cpupower
Failed to start cpupower.service: Unit cpupower.service failed to load: No such file or directory.
SERVER:~ # echo $?
5
SERVER:~ #
SERVER:~ # systemctl status cpupower
? cpupower.service
   Loaded: not-found (Reason: No such file or directory)
   Active: inactive (dead)
SERVER:~ #

Update for the update#1: I followed the https://www.suse.com/support/kb/doc/?id=7021316 but didn't helped.

Update#2: tried to set the freq but didn't helped.

SERVER:~ # lscpu | awk '/Model name:/{print $NF}'
2.20GHz
SERVER:~ # cpupower frequency-set -u 2.20GHz
...
SERVER:~ # cpupower frequency-set -u 2.2GHz
...
SERVER:~ # lscpu |egrep  "CPU MHz|CPU(s)" | awk '{print $3}' | awk -F "." '{print $1}'
1200
SERVER:~ #
2 added 398 characters in body
source | link

I tried:

cpupower frequency-set -g performance

But still, the frequency is only at 1200 MHz.

It only goes up if I put a load on the machine, but it should be running at always 100% cpu frequency.

Using SLES 12.2.

SERVER:~ # cat /proc/cmdline
BOOT_IMAGE=/vmlinuz-4.4.121-92.80-default root=/dev/mapper/vg00-lv_root splash=silent quiet showopts console=tty0 console=ttyS0,9600 elevator=noop transparent_hugepage=never crashkernel=768M numa_balancing=disable intel_idle.max_cstate=1
SERVER:~ #

What am I missing?

If it is maybe some UEFI settings, is there any command, ex.: asu64 to update the UEFI setting without a reboot?

Machine is a "x3850 X6", CPU is: " Xeon(R) CPU E7-8880 v4 @ 2.20GHz".

Found something, maybe:

SERVER:~ # systemctl start cpupower
Failed to start cpupower.service: Unit cpupower.service failed to load: No such file or directory.
SERVER:~ # echo $?
5
SERVER:~ #
SERVER:~ # systemctl status cpupower
? cpupower.service
   Loaded: not-found (Reason: No such file or directory)
   Active: inactive (dead)
SERVER:~ #

I tried:

cpupower frequency-set -g performance

But still, the frequency is only at 1200 MHz.

It only goes up if I put a load on the machine, but it should be running at always 100% cpu frequency.

Using SLES 12.2.

SERVER:~ # cat /proc/cmdline
BOOT_IMAGE=/vmlinuz-4.4.121-92.80-default root=/dev/mapper/vg00-lv_root splash=silent quiet showopts console=tty0 console=ttyS0,9600 elevator=noop transparent_hugepage=never crashkernel=768M numa_balancing=disable intel_idle.max_cstate=1
SERVER:~ #

What am I missing?

If it is maybe some UEFI settings, is there any command, ex.: asu64 to update the UEFI setting without a reboot?

Machine is a "x3850 X6", CPU is: " Xeon(R) CPU E7-8880 v4 @ 2.20GHz".

I tried:

cpupower frequency-set -g performance

But still, the frequency is only at 1200 MHz.

It only goes up if I put a load on the machine, but it should be running at always 100% cpu frequency.

Using SLES 12.2.

SERVER:~ # cat /proc/cmdline
BOOT_IMAGE=/vmlinuz-4.4.121-92.80-default root=/dev/mapper/vg00-lv_root splash=silent quiet showopts console=tty0 console=ttyS0,9600 elevator=noop transparent_hugepage=never crashkernel=768M numa_balancing=disable intel_idle.max_cstate=1
SERVER:~ #

What am I missing?

If it is maybe some UEFI settings, is there any command, ex.: asu64 to update the UEFI setting without a reboot?

Machine is a "x3850 X6", CPU is: " Xeon(R) CPU E7-8880 v4 @ 2.20GHz".

Found something, maybe:

SERVER:~ # systemctl start cpupower
Failed to start cpupower.service: Unit cpupower.service failed to load: No such file or directory.
SERVER:~ # echo $?
5
SERVER:~ #
SERVER:~ # systemctl status cpupower
? cpupower.service
   Loaded: not-found (Reason: No such file or directory)
   Active: inactive (dead)
SERVER:~ #
1
source | link

How to set the cpu frequency to the max on SLES12?

I tried:

cpupower frequency-set -g performance

But still, the frequency is only at 1200 MHz.

It only goes up if I put a load on the machine, but it should be running at always 100% cpu frequency.

Using SLES 12.2.

SERVER:~ # cat /proc/cmdline
BOOT_IMAGE=/vmlinuz-4.4.121-92.80-default root=/dev/mapper/vg00-lv_root splash=silent quiet showopts console=tty0 console=ttyS0,9600 elevator=noop transparent_hugepage=never crashkernel=768M numa_balancing=disable intel_idle.max_cstate=1
SERVER:~ #

What am I missing?

If it is maybe some UEFI settings, is there any command, ex.: asu64 to update the UEFI setting without a reboot?

Machine is a "x3850 X6", CPU is: " Xeon(R) CPU E7-8880 v4 @ 2.20GHz".