4 fix formatting
source | link

$ cat /usr/share/X11/xorg.conf.d/50-synaptics_trackpoint.conf Section "InputClass" Identifier "Synaptics TrackPoint" MatchProduct "Stick" # set the following to 1 1 0 respectively to disable acceleration. Option "AccelerationNumerator" "5" Option "AccelerationDenominator" "1" Option "AccelerationThreshold" "1" # linear deceleration (mouse speed reduction) Option "ConstantDeceleration" "2" # some curved deceleration Option "AdaptiveDeceleration" "1" EndSection

$ cat /usr/share/X11/xorg.conf.d/50-synaptics_trackpoint.conf
Section "InputClass"
        Identifier "Synaptics TrackPoint"
        MatchProduct "Stick"
        # set the following to 1 1 0 respectively to disable acceleration.
        Option "AccelerationNumerator" "5"
        Option "AccelerationDenominator" "1"
        Option "AccelerationThreshold" "1"
        # linear deceleration (mouse speed reduction)
        Option "ConstantDeceleration" "2"
        # some curved deceleration
        Option "AdaptiveDeceleration" "1"
EndSection

Rebooted, still no dice. FoundI found out that the XFCE was over-ridingoverriding the xorgXorg config, so I removed it:

Some of my troubleshooting notes: # Get the current acceleration values. xinput --get-feedbacks 11

# Get the current acceleration values.
xinput --get-feedbacks 11

# Get the current deceleration values.
xinput --list-props 11 | grep Deceleration

# What does Xorg know about this?
grep -i stick /var/log/Xorg.0.log

# Set acceleration.
xinput --set-ptr-feedback 11 1 5 1

# Set deceleration.
xinput --set-prop 11 'Device Accel Constant Deceleration' 2

More references   

Xorg PointerAcceleration Wiki xorg.conf man page

$ cat /usr/share/X11/xorg.conf.d/50-synaptics_trackpoint.conf Section "InputClass" Identifier "Synaptics TrackPoint" MatchProduct "Stick" # set the following to 1 1 0 respectively to disable acceleration. Option "AccelerationNumerator" "5" Option "AccelerationDenominator" "1" Option "AccelerationThreshold" "1" # linear deceleration (mouse speed reduction) Option "ConstantDeceleration" "2" # some curved deceleration Option "AdaptiveDeceleration" "1" EndSection

Rebooted, still no dice. Found out that the XFCE was over-riding the xorg config, so I removed it:

Some of my troubleshooting notes: # Get the current acceleration values. xinput --get-feedbacks 11

# Get the current deceleration values.
xinput --list-props 11 | grep Deceleration

# What does Xorg know about this?
grep -i stick /var/log/Xorg.0.log

# Set acceleration.
xinput --set-ptr-feedback 11 1 5 1

# Set deceleration.
xinput --set-prop 11 'Device Accel Constant Deceleration' 2

More references  Xorg PointerAcceleration Wiki xorg.conf man page

$ cat /usr/share/X11/xorg.conf.d/50-synaptics_trackpoint.conf
Section "InputClass"
        Identifier "Synaptics TrackPoint"
        MatchProduct "Stick"
        # set the following to 1 1 0 respectively to disable acceleration.
        Option "AccelerationNumerator" "5"
        Option "AccelerationDenominator" "1"
        Option "AccelerationThreshold" "1"
        # linear deceleration (mouse speed reduction)
        Option "ConstantDeceleration" "2"
        # some curved deceleration
        Option "AdaptiveDeceleration" "1"
EndSection

Rebooted, still no dice. I found out that the XFCE was overriding the Xorg config, so I removed it:

Some of my troubleshooting notes:

# Get the current acceleration values.
xinput --get-feedbacks 11

# Get the current deceleration values.
xinput --list-props 11 | grep Deceleration

# What does Xorg know about this?
grep -i stick /var/log/Xorg.0.log

# Set acceleration.
xinput --set-ptr-feedback 11 1 5 1

# Set deceleration.
xinput --set-prop 11 'Device Accel Constant Deceleration' 2

More references 

Xorg PointerAcceleration Wiki xorg.conf man page

3 Improved code formatting.
source | link

xinput --set-prop 11 'Device Accel Constant Deceleration' 3

xinput --set-prop 11 'Device Accel Constant Deceleration' 3

xset m 5 1

xset m 5 1

xinput --set-prop 11 'Device Accel Constant Deceleration' 3 &
xset m 5 1 &
exec ck-launch-session startxfce4

xinput --set-prop 11 'Device Accel Constant Deceleration' 3 &
xset m 5 1 &
exec ck-launch-session startxfce4

[EDIT:]
  More Information
  My .xinitrc does not work on Debian Testing/LightDM/XFCE not sure why. Decided to do the xorg.conf tweaking.


$ cat /usr/share/X11/xorg.conf.d/50-synaptics_trackpoint.conf  
Section "InputClass"  
        Identifier "Synaptics TrackPoint"  
        MatchProduct "Stick"
        # set the following to 1 1 0 respectively to disable acceleration.
        Option "AccelerationNumerator" "5"
        Option "AccelerationDenominator" "1"
        Option "AccelerationThreshold" "1"
        # linear deceleration (mouse speed reduction)
        Option "ConstantDeceleration" "2"
        # some curved deceleration
        Option "AdaptiveDeceleration" "1"
EndSection

$ cat /usr/share/X11/xorg.conf.d/50-synaptics_trackpoint.conf Section "InputClass" Identifier "Synaptics TrackPoint" MatchProduct "Stick" # set the following to 1 1 0 respectively to disable acceleration. Option "AccelerationNumerator" "5" Option "AccelerationDenominator" "1" Option "AccelerationThreshold" "1" # linear deceleration (mouse speed reduction) Option "ConstantDeceleration" "2" # some curved deceleration Option "AdaptiveDeceleration" "1" EndSection

$ rm ~/.config/xfce4/xfconf/xfce-perchannel-xml/pointers.xml

$ rm ~/.config/xfce4/xfconf/xfce-perchannel-xml/pointers.xml

Some of my troubleshooting notes: # Get the current acceleration values. xinput --get-feedbacks 11


# Get the current acceleration values.
xinput --get-feedbacks 11

# Get the current deceleration values.
xinput --list-props 11 | grep Deceleration

# What does Xorg know about this?
grep -i stick /var/log/Xorg.0.log

# Set acceleration.
xinput --set-ptr-feedback 11 1 5 1

# Set deceleration.
xinput --set-prop 11 'Device Accel Constant Deceleration' 2
# Get the current deceleration values.
xinput --list-props 11 | grep Deceleration

# What does Xorg know about this?
grep -i stick /var/log/Xorg.0.log

# Set acceleration.
xinput --set-ptr-feedback 11 1 5 1

# Set deceleration.
xinput --set-prop 11 'Device Accel Constant Deceleration' 2

More references
  Xorg PointerAcceleration Wiki
  xorg.conf man page  

xinput --set-prop 11 'Device Accel Constant Deceleration' 3

xset m 5 1

xinput --set-prop 11 'Device Accel Constant Deceleration' 3 &
xset m 5 1 &
exec ck-launch-session startxfce4

[EDIT:]
  More Information
  My .xinitrc does not work on Debian Testing/LightDM/XFCE not sure why. Decided to do the xorg.conf tweaking.


$ cat /usr/share/X11/xorg.conf.d/50-synaptics_trackpoint.conf  
Section "InputClass"  
        Identifier "Synaptics TrackPoint"  
        MatchProduct "Stick"
        # set the following to 1 1 0 respectively to disable acceleration.
        Option "AccelerationNumerator" "5"
        Option "AccelerationDenominator" "1"
        Option "AccelerationThreshold" "1"
        # linear deceleration (mouse speed reduction)
        Option "ConstantDeceleration" "2"
        # some curved deceleration
        Option "AdaptiveDeceleration" "1"
EndSection

$ rm ~/.config/xfce4/xfconf/xfce-perchannel-xml/pointers.xml

Some of my troubleshooting notes:


# Get the current acceleration values.
xinput --get-feedbacks 11

# Get the current deceleration values.
xinput --list-props 11 | grep Deceleration

# What does Xorg know about this?
grep -i stick /var/log/Xorg.0.log

# Set acceleration.
xinput --set-ptr-feedback 11 1 5 1

# Set deceleration.
xinput --set-prop 11 'Device Accel Constant Deceleration' 2

More references
  Xorg PointerAcceleration Wiki
  xorg.conf man page  

xinput --set-prop 11 'Device Accel Constant Deceleration' 3
xset m 5 1
xinput --set-prop 11 'Device Accel Constant Deceleration' 3 &
xset m 5 1 &
exec ck-launch-session startxfce4

[EDIT:] More Information My .xinitrc does not work on Debian Testing/LightDM/XFCE not sure why. Decided to do the xorg.conf tweaking.

$ cat /usr/share/X11/xorg.conf.d/50-synaptics_trackpoint.conf Section "InputClass" Identifier "Synaptics TrackPoint" MatchProduct "Stick" # set the following to 1 1 0 respectively to disable acceleration. Option "AccelerationNumerator" "5" Option "AccelerationDenominator" "1" Option "AccelerationThreshold" "1" # linear deceleration (mouse speed reduction) Option "ConstantDeceleration" "2" # some curved deceleration Option "AdaptiveDeceleration" "1" EndSection

$ rm ~/.config/xfce4/xfconf/xfce-perchannel-xml/pointers.xml

Some of my troubleshooting notes: # Get the current acceleration values. xinput --get-feedbacks 11

# Get the current deceleration values.
xinput --list-props 11 | grep Deceleration

# What does Xorg know about this?
grep -i stick /var/log/Xorg.0.log

# Set acceleration.
xinput --set-ptr-feedback 11 1 5 1

# Set deceleration.
xinput --set-prop 11 'Device Accel Constant Deceleration' 2

More references Xorg PointerAcceleration Wiki xorg.conf man page

    Bounty Ended with 50 reputation awarded by Eugene Beresovsky
2 added 1617 characters in body
source | link

I was having the exact same problem, but I think I've finally found a solution.

xinput --set-prop 11 'Device Accel Constant Deceleration' 3

allows the touchstick/trackpoint to be stable at close range, i.e. when trying to select text. Change the '3' up or down until you get something you like, I tried 2, 3, and 4 and settled on '3'. Then play with,

xset m 5 1

to adjusts the acceleration. The '5' is the acceleration multiplier and '1' is the number of pixels you need to move the cursor before acceleration kicks in, '5' allows me to zip across the screen nicely.

Last thing to do is incorporate these settings into my .xinitrc:

xinput --set-prop 11 'Device Accel Constant Deceleration' 3 &
xset m 5 1 &
exec ck-launch-session startxfce4

I found all this information on the ArchWiki.

Final note: I think this problem showed up because the recently added synaptics_usb kernel module does not have sane defaults for the trackpoint, so the problem was "exposed" by the new kernel module, but not a problem with synaptics_usb itself.

[EDIT:]
More Information
My .xinitrc does not work on Debian Testing/LightDM/XFCE not sure why. Decided to do the xorg.conf tweaking.

Created the config file:


$ cat /usr/share/X11/xorg.conf.d/50-synaptics_trackpoint.conf  
Section "InputClass"  
        Identifier "Synaptics TrackPoint"  
        MatchProduct "Stick"
        # set the following to 1 1 0 respectively to disable acceleration.
        Option "AccelerationNumerator" "5"
        Option "AccelerationDenominator" "1"
        Option "AccelerationThreshold" "1"
        # linear deceleration (mouse speed reduction)
        Option "ConstantDeceleration" "2"
        # some curved deceleration
        Option "AdaptiveDeceleration" "1"
EndSection

Rebooted, still no dice. Found out that the XFCE was over-riding the xorg config, so I removed it:

$ rm ~/.config/xfce4/xfconf/xfce-perchannel-xml/pointers.xml

Rebooted again, works as expected.

Some of my troubleshooting notes:


# Get the current acceleration values.
xinput --get-feedbacks 11

# Get the current deceleration values.
xinput --list-props 11 | grep Deceleration

# What does Xorg know about this?
grep -i stick /var/log/Xorg.0.log

# Set acceleration.
xinput --set-ptr-feedback 11 1 5 1

# Set deceleration.
xinput --set-prop 11 'Device Accel Constant Deceleration' 2

More references
Xorg PointerAcceleration Wiki
xorg.conf man page

I was having the exact same problem, but I think I've finally found a solution.

xinput --set-prop 11 'Device Accel Constant Deceleration' 3

allows the touchstick/trackpoint to be stable at close range, i.e. when trying to select text. Change the '3' up or down until you get something you like, I tried 2, 3, and 4 and settled on '3'. Then play with,

xset m 5 1

to adjusts the acceleration. The '5' is the acceleration multiplier and '1' is the number of pixels you need to move the cursor before acceleration kicks in, '5' allows me to zip across the screen nicely.

Last thing to do is incorporate these settings into my .xinitrc:

xinput --set-prop 11 'Device Accel Constant Deceleration' 3 &
xset 5 1 &
exec ck-launch-session startxfce4

I found all this information on the ArchWiki.

Final note: I think this problem showed up because the recently added synaptics_usb kernel module does not have sane defaults for the trackpoint, so the problem was "exposed" by the new kernel module, but not a problem with synaptics_usb itself.

I was having the exact same problem, but I think I've finally found a solution.

xinput --set-prop 11 'Device Accel Constant Deceleration' 3

allows the touchstick/trackpoint to be stable at close range, i.e. when trying to select text. Change the '3' up or down until you get something you like, I tried 2, 3, and 4 and settled on '3'. Then play with,

xset m 5 1

to adjusts the acceleration. The '5' is the acceleration multiplier and '1' is the number of pixels you need to move the cursor before acceleration kicks in, '5' allows me to zip across the screen nicely.

Last thing to do is incorporate these settings into my .xinitrc:

xinput --set-prop 11 'Device Accel Constant Deceleration' 3 &
xset m 5 1 &
exec ck-launch-session startxfce4

I found all this information on the ArchWiki.

Final note: I think this problem showed up because the recently added synaptics_usb kernel module does not have sane defaults for the trackpoint, so the problem was "exposed" by the new kernel module, but not a problem with synaptics_usb itself.

[EDIT:]
More Information
My .xinitrc does not work on Debian Testing/LightDM/XFCE not sure why. Decided to do the xorg.conf tweaking.

Created the config file:


$ cat /usr/share/X11/xorg.conf.d/50-synaptics_trackpoint.conf  
Section "InputClass"  
        Identifier "Synaptics TrackPoint"  
        MatchProduct "Stick"
        # set the following to 1 1 0 respectively to disable acceleration.
        Option "AccelerationNumerator" "5"
        Option "AccelerationDenominator" "1"
        Option "AccelerationThreshold" "1"
        # linear deceleration (mouse speed reduction)
        Option "ConstantDeceleration" "2"
        # some curved deceleration
        Option "AdaptiveDeceleration" "1"
EndSection

Rebooted, still no dice. Found out that the XFCE was over-riding the xorg config, so I removed it:

$ rm ~/.config/xfce4/xfconf/xfce-perchannel-xml/pointers.xml

Rebooted again, works as expected.

Some of my troubleshooting notes:


# Get the current acceleration values.
xinput --get-feedbacks 11

# Get the current deceleration values.
xinput --list-props 11 | grep Deceleration

# What does Xorg know about this?
grep -i stick /var/log/Xorg.0.log

# Set acceleration.
xinput --set-ptr-feedback 11 1 5 1

# Set deceleration.
xinput --set-prop 11 'Device Accel Constant Deceleration' 2

More references
Xorg PointerAcceleration Wiki
xorg.conf man page

1
source | link