2 deleted 69 characters in body
source | link

It's the first time that I install Linux (Debian testing) on a computer with UEFI and not BIOS. I've installed Windows first and then Debian (like I always did), but system keeps booting straight into Windows 10 no matter what.

I've tried many solutions: disabled secure-boot, tried multiple bios settings (CSM support enabled-disabled, UEFI boot only, UEFI and Legacy, etc), disabled Windows fastboot, tried installing rEFInd, tried with bcdedit from Windows shell, tried completely reinstalling the system..

The only way to boot into GRUB (which is installed and perfectly working) is to use a rEFInd USB. In this way I managed to add GRUB to EFI (which was missing) with efibootmgr EFI/debian/grubx64.efi command, but it's still not working.

Am I missing something? Can someone help me? I'm quite desperate.

My computer is a Thinkpad T470.

It's the first time that I install Linux (Debian testing) on a computer with UEFI and not BIOS. I've installed Windows first and then Debian (like I always did), but system keeps booting straight into Windows 10 no matter what.

I've tried many solutions: disabled secure-boot, tried multiple bios settings (CSM support enabled-disabled, UEFI boot only, UEFI and Legacy, etc), disabled Windows fastboot, tried installing rEFInd, tried with bcdedit from Windows shell, tried completely reinstalling the system..

The only way to boot into GRUB (which is installed and perfectly working) is to use a rEFInd USB. In this way I managed to add GRUB to EFI (which was missing) with efibootmgr EFI/debian/grubx64.efi command, but it's still not working.

Am I missing something? Can someone help me? I'm quite desperate.

My computer is a Thinkpad T470.

It's the first time that I install Linux (Debian testing) on a computer with UEFI and not BIOS. I've installed Windows first and then Debian (like I always did), but system keeps booting straight into Windows 10 no matter what.

I've tried many solutions: disabled secure-boot, tried multiple bios settings (CSM support enabled-disabled, UEFI boot only, UEFI and Legacy, etc), disabled Windows fastboot, tried installing rEFInd, tried with bcdedit from Windows shell, tried completely reinstalling the system..

The only way to boot into GRUB (which is installed and perfectly working) is to use a rEFInd USB. In this way I managed to add GRUB to EFI (which was missing) with efibootmgr EFI/debian/grubx64.efi command, but it's still not working.

My computer is a Thinkpad T470.

1
source | link

System skips grub and loads to Windows (UEFI)

It's the first time that I install Linux (Debian testing) on a computer with UEFI and not BIOS. I've installed Windows first and then Debian (like I always did), but system keeps booting straight into Windows 10 no matter what.

I've tried many solutions: disabled secure-boot, tried multiple bios settings (CSM support enabled-disabled, UEFI boot only, UEFI and Legacy, etc), disabled Windows fastboot, tried installing rEFInd, tried with bcdedit from Windows shell, tried completely reinstalling the system..

The only way to boot into GRUB (which is installed and perfectly working) is to use a rEFInd USB. In this way I managed to add GRUB to EFI (which was missing) with efibootmgr EFI/debian/grubx64.efi command, but it's still not working.

Am I missing something? Can someone help me? I'm quite desperate.

My computer is a Thinkpad T470.