Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange
2 updated and added new question
source | link

After much hit and try, this seems to be an effect of the vers option. If vers=2.1 is removed, unix extensions seem to get enabled:

//server.lan/aaditya on /home/roaming/SERVER/aaditya type cifs (rw,relatime,vers=1.0,cache=strict,username=aaditya,domain=SERVER,uid=1274545246,forceuid,gid=1274544641,forcegid,addr=192.168.1.191,unix,posixpaths,serverino,mapposix,acl,rsize=1048576,wsize=65536,echo_interval=60,actimeo=1)

The reason I had added vers=2.1 is because the samba share has a disk space quota, but with 1.0 the free space of whole disk is shown rather than that of the quota.

So the question now is: how to enable unix extensions for ver 2.1 of samba?

After much hit and try, this seems to be an effect of the vers option. If vers=2.1 is removed, unix extensions seem to get enabled:

//server.lan/aaditya on /home/roaming/SERVER/aaditya type cifs (rw,relatime,vers=1.0,cache=strict,username=aaditya,domain=SERVER,uid=1274545246,forceuid,gid=1274544641,forcegid,addr=192.168.1.191,unix,posixpaths,serverino,mapposix,acl,rsize=1048576,wsize=65536,echo_interval=60,actimeo=1)

After much hit and try, this seems to be an effect of the vers option. If vers=2.1 is removed, unix extensions seem to get enabled:

//server.lan/aaditya on /home/roaming/SERVER/aaditya type cifs (rw,relatime,vers=1.0,cache=strict,username=aaditya,domain=SERVER,uid=1274545246,forceuid,gid=1274544641,forcegid,addr=192.168.1.191,unix,posixpaths,serverino,mapposix,acl,rsize=1048576,wsize=65536,echo_interval=60,actimeo=1)

The reason I had added vers=2.1 is because the samba share has a disk space quota, but with 1.0 the free space of whole disk is shown rather than that of the quota.

So the question now is: how to enable unix extensions for ver 2.1 of samba?

1
source | link

After much hit and try, this seems to be an effect of the vers option. If vers=2.1 is removed, unix extensions seem to get enabled:

//server.lan/aaditya on /home/roaming/SERVER/aaditya type cifs (rw,relatime,vers=1.0,cache=strict,username=aaditya,domain=SERVER,uid=1274545246,forceuid,gid=1274544641,forcegid,addr=192.168.1.191,unix,posixpaths,serverino,mapposix,acl,rsize=1048576,wsize=65536,echo_interval=60,actimeo=1)