2 edited tags
| link
1
source | link

linux gdisk (on 4TB USB drive) followed my mkfs -- but mkfs doesn't see new partitions

I just bought two new 4TB external USB disks for backups

http://www.bestbuy.com/site/wd-my-passport-4tb-external-usb-3-0-portable-hard-drive-black/5605533.p

that came performatted with a single large ms partition. I'm running slackware 14.2x64, and ran gdisk to d(elete) that partition and make three n(ew) 1.2TB partitions (just dividing the total sectors by three). Then I w(rote) the partition table info and gdisk exited. And then both fdisk -l and gdisk -l /dev/sdb showed everything looking exactly like I'd expected it should.

But then mkfs -t ext4 /dev/sdb1 said it saw the original ms partition, and asked whether or not to proceed. I said no, and tried gdisk several more times, d(eleting) and re-n(ewing) all three partitions. Also tried sync, and tried unplugging the drive and re-plugging it. Nothing worked. I finally tried letting mkfs start to format the ms partition it reported, and killed it after a minute. Then re-ran gdisk yet again. And now, finally, mkfs saw the new partition table. And everything proceeded smoothly.

But what was I doing wrong? That is, how do you run gdisk so that the subsequent mkfs correctly and immediately sees the partition table you just w(rote) using gdisk? I wouldn't think that what I ended up doing is the recommended procedure.