2 added 467 characters in body
source | link

I think the third solution is the way to go when you have access to the router configuration. I would try setting the "RT-AC68U's Domain Name" to blank.

The next thing that I would do is run something like wireshark, and watch the packets sent and received by avahai-daemon, as well as any packets sent from and to any domain name ending in .local ... if something other than avahai is setting LAN domain names to .local you'll find it there.

It's also possible that the issue is something else entirely, and wireshark might tell you that as well.

If you're using Avahai entirely for the purpose of assigning domain names to machines on your network, you might consider using dnsmasq instead. You can run it off your RT-AC88U router, or from your Ubuntu box (In fact, it's probably already running on your ubuntu box, and you'll just need to tweak the config file).

Documentation for setting up dnsmasq under Asus-Merlin

I think the third solution is the way to go when you have access to the router configuration. I would try setting the "RT-AC68U's Domain Name" to blank.

The next thing that I would do is run something like wireshark, and watch the packets sent and received by avahai-daemon, as well as any packets sent from and to any domain name ending in .local ... if something other than avahai is setting LAN domain names to .local you'll find it there.

It's also possible that the issue is something else entirely, and wireshark might tell you that as well.

I think the third solution is the way to go when you have access to the router configuration. I would try setting the "RT-AC68U's Domain Name" to blank.

The next thing that I would do is run something like wireshark, and watch the packets sent and received by avahai-daemon, as well as any packets sent from and to any domain name ending in .local ... if something other than avahai is setting LAN domain names to .local you'll find it there.

It's also possible that the issue is something else entirely, and wireshark might tell you that as well.

If you're using Avahai entirely for the purpose of assigning domain names to machines on your network, you might consider using dnsmasq instead. You can run it off your RT-AC88U router, or from your Ubuntu box (In fact, it's probably already running on your ubuntu box, and you'll just need to tweak the config file).

Documentation for setting up dnsmasq under Asus-Merlin

1
source | link

I think the third solution is the way to go when you have access to the router configuration. I would try setting the "RT-AC68U's Domain Name" to blank.

The next thing that I would do is run something like wireshark, and watch the packets sent and received by avahai-daemon, as well as any packets sent from and to any domain name ending in .local ... if something other than avahai is setting LAN domain names to .local you'll find it there.

It's also possible that the issue is something else entirely, and wireshark might tell you that as well.