Post Closed as "duplicate" by Gilles, Kusalananda, countermode, Jeff Schaller, mdpc of
3 edited tags
| link
2 added 15 characters in body
source | link

I’m not able to execute the files in a mounted directory in my Ubuntu 16.04 VM. I get the error “command not found”:

dseltz-VirtualBox:/local> ls -al /nfs/local/gnu/i86Linux2.0/bin/makeheader

-rwxr-xr-x 1 systemd-network uucp 49379 Oct 20 1999 >/nfs/local/gnu/i86Linux2.0/bin/makeheader

dseltz-VirtualBox:/local> /nfs/local/gnu/i86Linux2.0/bin/makeheader /nfs/local/gnu/i86Linux2.0/bin/makeheader: Command not found.

My VM is a x64 running Ubuntu 16.04 and so is the mounted system.

I looked at the mounts and don’t see the noexec property(on either system).

Here is the mount command:

sudo mount -o exec 10.15.1.203:/local /nfs/local

I made sure my users matched on my VM machine and the build system.

Any ideas what I'm doing wrong?

I’m not able to execute the files in a mounted directory in my Ubuntu 16.04 VM. I get the error “command not found”:

dseltz-VirtualBox:/local> ls -al /local/gnu/i86Linux2.0/bin/makeheader

-rwxr-xr-x 1 systemd-network uucp 49379 Oct 20 1999 >/local/gnu/i86Linux2.0/bin/makeheader

dseltz-VirtualBox:/local> /local/gnu/i86Linux2.0/bin/makeheader /local/gnu/i86Linux2.0/bin/makeheader: Command not found.

My VM is a x64 running Ubuntu 16.04 and so is the mounted system.

I looked at the mounts and don’t see the noexec property(on either system).

Here is the mount command:

sudo mount -o exec 10.15.1.203:/local /nfs/local

I made sure my users matched on my VM machine and the build system.

Any ideas what I'm doing wrong?

I’m not able to execute the files in a mounted directory in my Ubuntu 16.04 VM. I get the error “command not found”:

dseltz-VirtualBox:/local> ls -al /nfs/local/gnu/i86Linux2.0/bin/makeheader

-rwxr-xr-x 1 systemd-network uucp 49379 Oct 20 1999 /nfs/local/gnu/i86Linux2.0/bin/makeheader

dseltz-VirtualBox:/local> /nfs/local/gnu/i86Linux2.0/bin/makeheader /nfs/local/gnu/i86Linux2.0/bin/makeheader: Command not found.

My VM is a x64 running Ubuntu 16.04 and so is the mounted system.

I looked at the mounts and don’t see the noexec property(on either system).

Here is the mount command:

sudo mount -o exec 10.15.1.203:/local /nfs/local

I made sure my users matched on my VM machine and the build system.

Any ideas what I'm doing wrong?

1
source | link

Getting “Command not found” when trying to execute mounted file

I’m not able to execute the files in a mounted directory in my Ubuntu 16.04 VM. I get the error “command not found”:

dseltz-VirtualBox:/local> ls -al /local/gnu/i86Linux2.0/bin/makeheader

-rwxr-xr-x 1 systemd-network uucp 49379 Oct 20 1999 >/local/gnu/i86Linux2.0/bin/makeheader

dseltz-VirtualBox:/local> /local/gnu/i86Linux2.0/bin/makeheader /local/gnu/i86Linux2.0/bin/makeheader: Command not found.

My VM is a x64 running Ubuntu 16.04 and so is the mounted system.

I looked at the mounts and don’t see the noexec property(on either system).

Here is the mount command:

sudo mount -o exec 10.15.1.203:/local /nfs/local

I made sure my users matched on my VM machine and the build system.

Any ideas what I'm doing wrong?