2 edited tags
| link
1
source | link

Dual monitor setup in Linux Mint 17.2 Rafaela

OK so I have been going at this problem hammer and tong for 6 days now (and over two weeks in a previous attempt).

My problem is setting up Linux Mint with an external monitor plugged into my laptop.

I have tried possibly every suggestion I could find online without success. And now I am ready to break my laptop for trying and failing!


My System and Hardware

  • Laptop: Asus X5DC
  • lspci | grep -i vga output: 01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10)
  • External monitor: ViewSonic VX912
  • xrandr output: xrandr: Failed to get size of gamma for output default Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768 default connected primary 1024x768+0+0 0mm x 0mm 1024x768 76.0* 1504x1200_60.00 (0x1ab) 151.4MHz h: width 1504 start 1608 end 1768 total 2032 skew 0 clock 74.5KHz v: height 1200 start 1201 end 1204 total 1242 clock 60.0Hz
  • sudo lshw -C video output: *-display UNCLAIMED description: VGA compatible controller product: 771/671 PCIE VGA Display Adapter vendor: Silicon Integrated Systems [SiS] physical id: 0 bus info: pci@0000:01:00.0 version: 10 width: 32 bits clock: 66MHz capabilities: pm agp agp-3.0 vga_controller cap_list configuration: latency=0 resources: memory:d0000000-dfffffff memory:fe9e0000-fe9fffff ioport:dc00(size=128)

What I have tried already

  • Editing /etc/X11/xorg.conf many times and sometimes X wouldn't start so I had to undo my changes from tty terminal and restart. Here is my current xorg.conf:

    Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen         "Screen0" LeftOf "Screen1"
    EndSection
    
    Section "Monitor"
        Identifier   "Configured Monitor"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
        HorizSync 28-72
        VertRefresh 43-60
    EndSection
    
    Section "Device"
        Identifier  "Card0"
        Driver      "sis"
        BusID       "PCI:1:0:0"
    EndSection
    
    Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
            Viewport   0 0
            Depth     1
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     4
            Modes      "900x675" "1024x768" "1280x960" "1400x1050"
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     8
            Modes      "900x675" "1024x768" "1280x960" "1400x1050"
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     15
            Modes      "900x675" "1024x768" "1280x960" "1400x1050"
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     16
            Modes      "900x675" "1024x768" "1280x960" "1400x1050"
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     24
            Modes      "900x675" "1024x768" "1280x960" "1400x1050"
        EndSubSection
    EndSection
    
    Section "Screen"
        Identifier "Screen1"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
            Viewport   0 0
            Depth     1
            Modes      "1280x1024" "1500x1200" "1640x1312"
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     4
            Modes      "1280x1024" "1500x1200" "1640x1312"
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     8
            Modes      "1280x1024" "1500x1200" "1640x1312"
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     15
            Modes      "1280x1024" "1500x1200" "1640x1312"
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     16
            Modes      "1280x1024" "1500x1200" "1640x1312"
        EndSubSection
        SubSection "Display"
            Viewport   0 0
            Depth     24
            Modes      "1280x1024" "1500x1200" "1640x1312"
        EndSubSection
    EndSection
    

    `

  • I have added the following .conf files to /usr/share/X11/xorg.conf.d:

    • 41-built-in-monitor.conf which contains:

          Section "Monitor"
              Identifier   "Monitor0"
              VendorName   "Built in Monitor"
              ModelName    "Model Unknown"
              HorizSync       28.0 - 70.0
              VertRefresh     56.0 - 75.0
          EndSection
      
    • 42-second-vga-monitor.conf which contains:

          Section "Monitor"
              Identifier   "Monitor1"
              VendorName   "ViewSonic"
              ModelName    "VX912"
              Option       "RightOf"  "Monitor0"
              HorizSync       28.0 - 70.0
              VertRefresh     56.0 - 75.0
          Endsection
      
    • 50-video.conf which contains:

          Section "Device"
              Identifier "Device2"
              Option  "Monitor-Built-In" "Monitor0"
              Option  "Monitor-VGA"      "Monitor1"
              Driver "sis"
          EndSection
      
  • sudo update-pciids

  • gtf 1500 1200 60 -x output: # 1504x1200 @ 60.00 Hz (GTF) hsync: 74.52 kHz; pclk: 151.42 MHz Modeline "1504x1200_60.00" 151.42 1504 1608 1768 2032 1200 1201 1204 1242 -HSync +Vsync
  • xrandr --newmode "1504x1200_60.00" 151.42 1504 1608 1768 2032 1200 1201 1204 1242 -HSync +Vsync output: xrandr: Failed to get size of gamma for output default X Error of failed request: BadName (named color or font does not exist) Major opcode of failed request: 140 (RANDR) Minor opcode of failed request: 16 (RRCreateMode) Serial number of failed request: 19 Current serial number in output stream: 19
  • xrandr --addmode VGA1 1504x1200_60.00 output: xrandr: Failed to get size of gamma for output default xrandr: cannot find output "VGA1"
  • xrandr --output VGA1 --mode 1504x1200_60.00 output: xrandr: Failed to get size of gamma for output default warning: output VGA1 not found; ignoring

And many more suggestions I found, in fact I'e tried that many things I could not list them here even if I could remember!


Mate Monitor Preferences does not recognize external monitor (obviously).

Arandr acts as though I only have the 'default' monitor.

My system is displaying on both screens but not seperately, as in its the same on both monitors, so the monitor works and the VGA adapter works and the graphics card can output to both, just not as a proper dual monitor setup.

If anyone knows what exactly is ~/.config/monitors.xml for?