2 added 69 characters in body
source | link

I've had the following in my ~/.vimrc for years:

autocmd BufNewFile,BufRead /tmp/mutt* set noautoindent filetype=mail wm=0 tw=78 nonumber digraph nolist
autocmd BufNewFile,BufRead ~/tmp/mutt* set noautoindent filetype=mail wm=0 tw=78 nonumber digraph nolist

They tell vim to set those options when editing matching files.

It works well for me. The only thing i'dI'd consider adding would be to set paste as well as noautoindent.

BTW, I write all my email in mutt with vim - I wouldn't/couldn't use anything else....even when I had to use Icedove (aka Thunderbird) at $a_previous_job years ago to connect to their Exchange server, I had the External Editor plugin installed so I could use gvim. I eventually switched to using mutt+vim+fetchmail - direct imap connections to the Exchange server timed out in about 60 seconds, nowhere long enough to write anything but the shortest msg in vim.

I've had the following in my ~/.vimrc for years:

autocmd BufNewFile,BufRead /tmp/mutt* set noautoindent filetype=mail wm=0 tw=78 nonumber digraph nolist
autocmd BufNewFile,BufRead ~/tmp/mutt* set noautoindent filetype=mail wm=0 tw=78 nonumber digraph nolist

It works well for me. The only thing i'd consider adding would be to set paste as well as noautoindent.

BTW, I write all my email in mutt with vim - I wouldn't/couldn't use anything else....even when I had to use Icedove (aka Thunderbird) at $a_previous_job years ago to connect to their Exchange server, I had the External Editor plugin installed so I could use gvim. I eventually switched to using mutt+vim+fetchmail - direct imap connections to the Exchange server timed out in about 60 seconds, nowhere long enough to write anything but the shortest msg in vim.

I've had the following in my ~/.vimrc for years:

autocmd BufNewFile,BufRead /tmp/mutt* set noautoindent filetype=mail wm=0 tw=78 nonumber digraph nolist
autocmd BufNewFile,BufRead ~/tmp/mutt* set noautoindent filetype=mail wm=0 tw=78 nonumber digraph nolist

They tell vim to set those options when editing matching files.

It works well for me. The only thing I'd consider adding would be to set paste as well as noautoindent.

BTW, I write all my email in mutt with vim - I wouldn't/couldn't use anything else....even when I had to use Icedove (aka Thunderbird) at $a_previous_job years ago to connect to their Exchange server, I had the External Editor plugin installed so I could use gvim. I eventually switched to using mutt+vim+fetchmail - direct imap connections to the Exchange server timed out in about 60 seconds, nowhere long enough to write anything but the shortest msg in vim.

1
source | link

I've had the following in my ~/.vimrc for years:

autocmd BufNewFile,BufRead /tmp/mutt* set noautoindent filetype=mail wm=0 tw=78 nonumber digraph nolist
autocmd BufNewFile,BufRead ~/tmp/mutt* set noautoindent filetype=mail wm=0 tw=78 nonumber digraph nolist

It works well for me. The only thing i'd consider adding would be to set paste as well as noautoindent.

BTW, I write all my email in mutt with vim - I wouldn't/couldn't use anything else....even when I had to use Icedove (aka Thunderbird) at $a_previous_job years ago to connect to their Exchange server, I had the External Editor plugin installed so I could use gvim. I eventually switched to using mutt+vim+fetchmail - direct imap connections to the Exchange server timed out in about 60 seconds, nowhere long enough to write anything but the shortest msg in vim.