2 replaced http://unix.stackexchange.com/ with https://unix.stackexchange.com/
source | link

I am trying to run pacman from a script. The problem is that a package should be installed that conflicts and provides, but not replaces a currently installed package. As answered herehere I passed the --noconfirm option and since pacman's stdin is not pointing to a tty it assumed the default answer which is no. How can I enforce pacman to answer yes to all questions? Please note that I can't pass any input to pacman (it's run via makechrootpkg) so I'm unable to use the yes command or similar as suggested herehere.

Here is the output of pacman:

loading packages...
resolving dependencies...
looking for conflicting packages...
:: libinput-ubuntu and libinput are in conflict. Remove libinput? [y/N] 
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)

I am trying to run pacman from a script. The problem is that a package should be installed that conflicts and provides, but not replaces a currently installed package. As answered here I passed the --noconfirm option and since pacman's stdin is not pointing to a tty it assumed the default answer which is no. How can I enforce pacman to answer yes to all questions? Please note that I can't pass any input to pacman (it's run via makechrootpkg) so I'm unable to use the yes command or similar as suggested here.

Here is the output of pacman:

loading packages...
resolving dependencies...
looking for conflicting packages...
:: libinput-ubuntu and libinput are in conflict. Remove libinput? [y/N] 
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)

I am trying to run pacman from a script. The problem is that a package should be installed that conflicts and provides, but not replaces a currently installed package. As answered here I passed the --noconfirm option and since pacman's stdin is not pointing to a tty it assumed the default answer which is no. How can I enforce pacman to answer yes to all questions? Please note that I can't pass any input to pacman (it's run via makechrootpkg) so I'm unable to use the yes command or similar as suggested here.

Here is the output of pacman:

loading packages...
resolving dependencies...
looking for conflicting packages...
:: libinput-ubuntu and libinput are in conflict. Remove libinput? [y/N] 
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
1
source | link

How to force pacman to answer yes to all questions?

I am trying to run pacman from a script. The problem is that a package should be installed that conflicts and provides, but not replaces a currently installed package. As answered here I passed the --noconfirm option and since pacman's stdin is not pointing to a tty it assumed the default answer which is no. How can I enforce pacman to answer yes to all questions? Please note that I can't pass any input to pacman (it's run via makechrootpkg) so I'm unable to use the yes command or similar as suggested here.

Here is the output of pacman:

loading packages...
resolving dependencies...
looking for conflicting packages...
:: libinput-ubuntu and libinput are in conflict. Remove libinput? [y/N] 
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)