4 added 1513 characters in body
source | link

edit this is the contents of my /etc/schroot folder

tree /etc/schroot/
/etc/schroot/
├── buildd
├── chroot.d
│   └── jessie-amd64-sbuild-k92zq_
├── default
├── desktop
├── minimal
├── sbuild
└── setup.d
    └── 99check -> 00check

7 directories, 2 files

this is the content of that jessie-amd64 file

cat /etc/schroot/chroot.d/jessie-amd64-sbuild-k92zq_ 
[jessie-amd64-sbuild]
type=file
description=Debian jessie/amd64 autobuilder
file=/srv/chroot/jessie-amd64.tar.gz
groups=root,sbuild
root-groups=root,sbuild
profile=sbuild

when I run

schroot -c jessie-amd64-sbuild
E: /etc/schroot/schroot.conf: Failed to stat file: No such file or directory

schroot -c jessie-amd64
E: /etc/schroot/schroot.conf: Failed to stat file: No such file or directory

They still just give an error even though I am using the -c command, it's complaining about the schroot.conf file.

I've tried to write this to the schroot.conf file

cat /etc/schroot/schroot.conf 
[jessie-amd64]
type=file
description=Debian jessie/amd64 autobuilder
file=/srv/chroot/jessie-amd64.tar.gz
groups=root,sbuild
root-groups=root,sbuild
profile=sbuild

then tried to run schroot -c /etc/schroot/schroot.conf

schroot -c jessie-amd64
E: /srv/chroot/jessie-amd64.tar.gz: Failed to stat file: No such file or directory

then I get the above error.

edit this is the contents of my /etc/schroot folder

tree /etc/schroot/
/etc/schroot/
├── buildd
├── chroot.d
│   └── jessie-amd64-sbuild-k92zq_
├── default
├── desktop
├── minimal
├── sbuild
└── setup.d
    └── 99check -> 00check

7 directories, 2 files

this is the content of that jessie-amd64 file

cat /etc/schroot/chroot.d/jessie-amd64-sbuild-k92zq_ 
[jessie-amd64-sbuild]
type=file
description=Debian jessie/amd64 autobuilder
file=/srv/chroot/jessie-amd64.tar.gz
groups=root,sbuild
root-groups=root,sbuild
profile=sbuild

when I run

schroot -c jessie-amd64-sbuild
E: /etc/schroot/schroot.conf: Failed to stat file: No such file or directory

schroot -c jessie-amd64
E: /etc/schroot/schroot.conf: Failed to stat file: No such file or directory

They still just give an error even though I am using the -c command, it's complaining about the schroot.conf file.

I've tried to write this to the schroot.conf file

cat /etc/schroot/schroot.conf 
[jessie-amd64]
type=file
description=Debian jessie/amd64 autobuilder
file=/srv/chroot/jessie-amd64.tar.gz
groups=root,sbuild
root-groups=root,sbuild
profile=sbuild

then tried to run schroot -c /etc/schroot/schroot.conf

schroot -c jessie-amd64
E: /srv/chroot/jessie-amd64.tar.gz: Failed to stat file: No such file or directory

then I get the above error.

3 added 3 characters in body
source | link

editEdit: I

I do not have the below file or folders nor do I really know how to manually create them. The wiki didn't really say much about these files.

edit I do not have the below file or folders nor do I really know how to manually create them. The wiki didn't really say much about these files.

Edit:

I do not have the below file or folders nor do I really know how to manually create them. The wiki didn't really say much about these files.

2 added 12 characters in body
source | link

TryingI am trying to package an ubuntuUbuntu package as a debianDebian package for. For maintainability I am trying to use sbuildsbuild.

I go through the first five steps, but when I try to build I get chroot errors.

theseThese are the steps:

The sbuild-createchrrotsbuild-createchrrot command that I use is: CODE: SELECT ALL

itIt continues until it finishes, I am not sure if these are errors, but this happens right before I regain control over the terminal.

afterAfter that I try to run:

thenThen I get this error:

thenThen the cursor just sits there blinking.

What is wrong with the chroot? How come sbuildsbuild isn't setting it up properly? How do I fix this to use sbuildsbuild?

Trying to package an ubuntu package as a debian package for maintainability I am trying to use sbuild.

I go through the first five steps but when I try to build I get chroot errors.

these are the steps:

The sbuild-createchrrot command that I use is: CODE: SELECT ALL

it continues until it finishes, I am not sure if these are errors but this happens right before I regain control over the terminal.

after that I try to run

then I get this error:

then the cursor just sits there blinking.

What is wrong with the chroot? How come sbuild isn't setting it up properly? How do I fix this to use sbuild?

I am trying to package an Ubuntu package as a Debian package. For maintainability I am trying to use sbuild.

I go through the first five steps, but when I try to build I get chroot errors.

These are the steps:

The sbuild-createchrrot command that I use is: CODE: SELECT ALL

It continues until it finishes, I am not sure if these are errors, but this happens right before I regain control over the terminal.

After that I try to run:

Then I get this error:

Then the cursor just sits there blinking.

What is wrong with the chroot? How come sbuild isn't setting it up properly? How do I fix this to use sbuild?

1
source | link