2 Explaining how to reverse. I swear t's the last edit.
source | link

You could try to check if the problem is with PulseAudio or not, by disabling it temporarily in configs and instead enabling Alsa's mixer thingie.

  1. Disable PulseAudio:

    echo autospawn=no > ~/.pulse/client.conf
    pulseaudio -k
    
  2. Enable dmix, Alsa's native mixer:

    sudo gedit ~/.asoundrc
    

    to open the .asoundrc config file, and then paste:

    pcm.!default {
        type plug
        slave.pcm "dmixer"
    }
    
    pcm.dmixer  {
        type dmix
        ipc_key 1024
        slave {
        pcm "hw:1,0"
        period_time 0
        period_size 1024
        buffer_size 4096
        rate 44100
    }
    bindings {
        0 0
        1 1
    }
    }
    
    ctl.dmixer {
    type hw
    card 0
    }
    

    reboot your computer and see if sound works. If it works, it's a problem with PulseAudio, if it doesn't (even with for example Youtube, or with VLC player when tried with all sound output options), it's most likely a driver or hardware problem. If it works and you can't figure out what was wrong with PA, you may want to keep it like that, I used that setting (slightly modified) for over a year and the only program I tried that has problems with it is Skype.

To reverse the effects simply delete the ~/.pulse/client.conf and ~/.asoundrc files and reboot.

You could try to check if the problem is with PulseAudio or not, by disabling it temporarily in configs and instead enabling Alsa's mixer thingie.

  1. Disable PulseAudio:

    echo autospawn=no > ~/.pulse/client.conf
    pulseaudio -k
    
  2. Enable dmix, Alsa's native mixer:

    sudo gedit ~/.asoundrc
    

    to open the .asoundrc config file, and then paste:

    pcm.!default {
        type plug
        slave.pcm "dmixer"
    }
    
    pcm.dmixer  {
        type dmix
        ipc_key 1024
        slave {
        pcm "hw:1,0"
        period_time 0
        period_size 1024
        buffer_size 4096
        rate 44100
    }
    bindings {
        0 0
        1 1
    }
    }
    
    ctl.dmixer {
    type hw
    card 0
    }
    

    reboot your computer and see if sound works. If it works, it's a problem with PulseAudio, if it doesn't (even with for example Youtube, or with VLC player when tried with all sound output options), it's most likely a driver or hardware problem. If it works and you can't figure out what was wrong with PA, you may want to keep it like that, I used that setting (slightly modified) for over a year and the only program I tried that has problems with it is Skype.

You could try to check if the problem is with PulseAudio or not, by disabling it temporarily in configs and instead enabling Alsa's mixer thingie.

  1. Disable PulseAudio:

    echo autospawn=no > ~/.pulse/client.conf
    pulseaudio -k
    
  2. Enable dmix, Alsa's native mixer:

    sudo gedit ~/.asoundrc
    

    to open the .asoundrc config file, and then paste:

    pcm.!default {
        type plug
        slave.pcm "dmixer"
    }
    
    pcm.dmixer  {
        type dmix
        ipc_key 1024
        slave {
        pcm "hw:1,0"
        period_time 0
        period_size 1024
        buffer_size 4096
        rate 44100
    }
    bindings {
        0 0
        1 1
    }
    }
    
    ctl.dmixer {
    type hw
    card 0
    }
    

    reboot your computer and see if sound works. If it works, it's a problem with PulseAudio, if it doesn't (even with for example Youtube, or with VLC player when tried with all sound output options), it's most likely a driver or hardware problem. If it works and you can't figure out what was wrong with PA, you may want to keep it like that, I used that setting (slightly modified) for over a year and the only program I tried that has problems with it is Skype.

To reverse the effects simply delete the ~/.pulse/client.conf and ~/.asoundrc files and reboot.

    Post Undeleted by Deuxis
    Post Deleted by Deuxis
1
source | link

You could try to check if the problem is with PulseAudio or not, by disabling it temporarily in configs and instead enabling Alsa's mixer thingie.

  1. Disable PulseAudio:

    echo autospawn=no > ~/.pulse/client.conf
    pulseaudio -k
    
  2. Enable dmix, Alsa's native mixer:

    sudo gedit ~/.asoundrc
    

    to open the .asoundrc config file, and then paste:

    pcm.!default {
        type plug
        slave.pcm "dmixer"
    }
    
    pcm.dmixer  {
        type dmix
        ipc_key 1024
        slave {
        pcm "hw:1,0"
        period_time 0
        period_size 1024
        buffer_size 4096
        rate 44100
    }
    bindings {
        0 0
        1 1
    }
    }
    
    ctl.dmixer {
    type hw
    card 0
    }
    

    reboot your computer and see if sound works. If it works, it's a problem with PulseAudio, if it doesn't (even with for example Youtube, or with VLC player when tried with all sound output options), it's most likely a driver or hardware problem. If it works and you can't figure out what was wrong with PA, you may want to keep it like that, I used that setting (slightly modified) for over a year and the only program I tried that has problems with it is Skype.