2 added 119 characters in body
source | link

The problem is probably that your newer /bin/mail program is adding its own Mime header to the mail, overriding your Content-Type: text/html hack that you have tacked onto the end of the Subject: header.

An easy solution is to bypass mail and simply go straight to sendmail (even if using postfix). Replace your command with:

sendmail -t <<!
From: test@test.com
To: testr@test.com
Subject: This is the subject
MIME-Version: 1.0
Content-Type: text/html; charset=us-ascii
Content-Transfer-Encoding: 7bit

<b>HTML Message <i>goes</i> here</b>
!

If your sendmail doesn't accept -t then remplace that option by the address you are sending to, ie testr@test.com.

The problem is probably that your newer /bin/mail program is adding its own Mime header to the mail, overriding your Content-Type: text/html hack that you have tacked onto the end of the Subject: header.

An easy solution is to bypass mail and simply go straight to sendmail (even if using postfix). Replace your command with:

sendmail -t <<!
From: test@test.com
To: testr@test.com
Subject: This is the subject
MIME-Version: 1.0
Content-Type: text/html; charset=us-ascii
Content-Transfer-Encoding: 7bit

<b>HTML Message <i>goes</i> here</b>
!

The problem is probably that your newer /bin/mail program is adding its own Mime header to the mail, overriding your Content-Type: text/html hack that you have tacked onto the end of the Subject: header.

An easy solution is to bypass mail and simply go straight to sendmail (even if using postfix). Replace your command with:

sendmail -t <<!
From: test@test.com
To: testr@test.com
Subject: This is the subject
MIME-Version: 1.0
Content-Type: text/html; charset=us-ascii
Content-Transfer-Encoding: 7bit

<b>HTML Message <i>goes</i> here</b>
!

If your sendmail doesn't accept -t then remplace that option by the address you are sending to, ie testr@test.com.

1
source | link

The problem is probably that your newer /bin/mail program is adding its own Mime header to the mail, overriding your Content-Type: text/html hack that you have tacked onto the end of the Subject: header.

An easy solution is to bypass mail and simply go straight to sendmail (even if using postfix). Replace your command with:

sendmail -t <<!
From: test@test.com
To: testr@test.com
Subject: This is the subject
MIME-Version: 1.0
Content-Type: text/html; charset=us-ascii
Content-Transfer-Encoding: 7bit

<b>HTML Message <i>goes</i> here</b>
!