2 replaced http://superuser.com/ with https://superuser.com/
source | link

I know and admit that the same question has been asked multiple times in the same forum as well as in others. However, none of those seem to work for me. I would post a detailed analysis and the steps I have taken up to setup the network adapter in Kali Linux on VirtualBox in Windows 8.1

The uname -r command yields the following: "4.0.0-kali-amd64" -- gives the version I'm running for Kali Linux.

VirtualBox version I'm running: 4.3.6 r91406

I have installed Kali linux on the virtual box. My network adapter settings are: 1. Bridged on Adapter 1 -- To connect to the internet 2. Host-only on Adapter 2 -- to communicate between my host machine and guest OS

Now, initially, I was not able to ping and ssh into my guest OS from windows. "ifconfig -a" use to show eth0 and lo, but with no inet address on eth0. So, I changed my settings as shown in the following url: https://wiki.debian.org/NetworkConfiguration which says to add the following in /etc/network/interfaces file: auto eth0 allow-hotplug eth0 iface eth0 inet dhcp

What it did was, as shown by "ifconfig -a", it created a new interface, eth1, and assigned it an ip address. However, my eth0 has still not been assigned any ip address, and running the command: "ping www.google.com" shows unknown host www.google.com

In addition, following the given url: http://superuser.com/questions/678893/cant-access-internet-in-kali-virtualboxhttps://superuser.com/questions/678893/cant-access-internet-in-kali-virtualbox also resulted in no change and I'm still not able to connect to the internet.

Note: It did remove the ssh problem, i.e. allowing me to ssh from windows on the address provided by eth1 -- 192.168.X.X

I know and admit that the same question has been asked multiple times in the same forum as well as in others. However, none of those seem to work for me. I would post a detailed analysis and the steps I have taken up to setup the network adapter in Kali Linux on VirtualBox in Windows 8.1

The uname -r command yields the following: "4.0.0-kali-amd64" -- gives the version I'm running for Kali Linux.

VirtualBox version I'm running: 4.3.6 r91406

I have installed Kali linux on the virtual box. My network adapter settings are: 1. Bridged on Adapter 1 -- To connect to the internet 2. Host-only on Adapter 2 -- to communicate between my host machine and guest OS

Now, initially, I was not able to ping and ssh into my guest OS from windows. "ifconfig -a" use to show eth0 and lo, but with no inet address on eth0. So, I changed my settings as shown in the following url: https://wiki.debian.org/NetworkConfiguration which says to add the following in /etc/network/interfaces file: auto eth0 allow-hotplug eth0 iface eth0 inet dhcp

What it did was, as shown by "ifconfig -a", it created a new interface, eth1, and assigned it an ip address. However, my eth0 has still not been assigned any ip address, and running the command: "ping www.google.com" shows unknown host www.google.com

In addition, following the given url: http://superuser.com/questions/678893/cant-access-internet-in-kali-virtualbox also resulted in no change and I'm still not able to connect to the internet.

Note: It did remove the ssh problem, i.e. allowing me to ssh from windows on the address provided by eth1 -- 192.168.X.X

I know and admit that the same question has been asked multiple times in the same forum as well as in others. However, none of those seem to work for me. I would post a detailed analysis and the steps I have taken up to setup the network adapter in Kali Linux on VirtualBox in Windows 8.1

The uname -r command yields the following: "4.0.0-kali-amd64" -- gives the version I'm running for Kali Linux.

VirtualBox version I'm running: 4.3.6 r91406

I have installed Kali linux on the virtual box. My network adapter settings are: 1. Bridged on Adapter 1 -- To connect to the internet 2. Host-only on Adapter 2 -- to communicate between my host machine and guest OS

Now, initially, I was not able to ping and ssh into my guest OS from windows. "ifconfig -a" use to show eth0 and lo, but with no inet address on eth0. So, I changed my settings as shown in the following url: https://wiki.debian.org/NetworkConfiguration which says to add the following in /etc/network/interfaces file: auto eth0 allow-hotplug eth0 iface eth0 inet dhcp

What it did was, as shown by "ifconfig -a", it created a new interface, eth1, and assigned it an ip address. However, my eth0 has still not been assigned any ip address, and running the command: "ping www.google.com" shows unknown host www.google.com

In addition, following the given url: https://superuser.com/questions/678893/cant-access-internet-in-kali-virtualbox also resulted in no change and I'm still not able to connect to the internet.

Note: It did remove the ssh problem, i.e. allowing me to ssh from windows on the address provided by eth1 -- 192.168.X.X

1
source | link

Not able to ping and connect to internet from Kali Linux in Virtual Box

I know and admit that the same question has been asked multiple times in the same forum as well as in others. However, none of those seem to work for me. I would post a detailed analysis and the steps I have taken up to setup the network adapter in Kali Linux on VirtualBox in Windows 8.1

The uname -r command yields the following: "4.0.0-kali-amd64" -- gives the version I'm running for Kali Linux.

VirtualBox version I'm running: 4.3.6 r91406

I have installed Kali linux on the virtual box. My network adapter settings are: 1. Bridged on Adapter 1 -- To connect to the internet 2. Host-only on Adapter 2 -- to communicate between my host machine and guest OS

Now, initially, I was not able to ping and ssh into my guest OS from windows. "ifconfig -a" use to show eth0 and lo, but with no inet address on eth0. So, I changed my settings as shown in the following url: https://wiki.debian.org/NetworkConfiguration which says to add the following in /etc/network/interfaces file: auto eth0 allow-hotplug eth0 iface eth0 inet dhcp

What it did was, as shown by "ifconfig -a", it created a new interface, eth1, and assigned it an ip address. However, my eth0 has still not been assigned any ip address, and running the command: "ping www.google.com" shows unknown host www.google.com

In addition, following the given url: http://superuser.com/questions/678893/cant-access-internet-in-kali-virtualbox also resulted in no change and I'm still not able to connect to the internet.

Note: It did remove the ssh problem, i.e. allowing me to ssh from windows on the address provided by eth1 -- 192.168.X.X