2 deleted 2 characters in body
source | link

Not sure if it helps (as not purely in setxkbmap), but:

setxkbmap -option ctrlcaps:nocapsnone
xmodmap -e "keycode 66 = Linefeed"

Change back:

setxkbmap -option
xmodmap -e "keycode 66 = Caps_Lock"

You can check with something like:

xev | sed -ne '/^KeyPress/,/^$/p'

to get keycodes.

Not sure if it helps (as not purely in setxkbmap), but:

setxkbmap -option ctrl:nocaps
xmodmap -e "keycode 66 = Linefeed"

Change back:

setxkbmap -option
xmodmap -e "keycode 66 = Caps_Lock"

You can check with something like:

xev | sed -ne '/^KeyPress/,/^$/p'

to get keycodes.

Not sure if it helps (as not purely in setxkbmap), but:

setxkbmap -option caps:none
xmodmap -e "keycode 66 = Linefeed"

Change back:

setxkbmap -option
xmodmap -e "keycode 66 = Caps_Lock"

You can check with something like:

xev | sed -ne '/^KeyPress/,/^$/p'

to get keycodes.

    Post Undeleted by user367890
    Post Deleted by user367890
1
source | link

Not sure if it helps (as not purely in setxkbmap), but:

setxkbmap -option ctrl:nocaps
xmodmap -e "keycode 66 = Linefeed"

Change back:

setxkbmap -option
xmodmap -e "keycode 66 = Caps_Lock"

You can check with something like:

xev | sed -ne '/^KeyPress/,/^$/p'

to get keycodes.