2 deleted 3 characters in body; edited tags; edited title
source | link

Trying to install pcsc-lite on RHEL 6.6 but system is saying pcsc-ifd-handler is needed Installing RPM packages with circular dependency

I'm trying to follow this article:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Managing_Smart_Cards/enabling-smart-card-login.htmlan article to enable smart card login

to enable smart card login on my RHEL 6.6 desktop. When I attempt to install coolkey-1.1.0, it says ccid and pcsc-lite is needed.

When attempt to install ccid-1.3.9.7, it says pcsc-lite is needed.

When I attempt to install pcsc-lite-1.5.2, it says pcsc-ifd-handler is required.

When I search Google to see what rpm I need to get pcsc-ifd-handler, it looks like pcsc-ifd-handler is included in the ccid or pcsc-lite-openct package (https://bugzilla.redhat.com/show_bug.cgi?id=144738).

  • When attempt to install ccid-1.3.9.7, it says pcsc-lite is needed.
  • When I attempt to install pcsc-lite-1.5.2, it says pcsc-ifd-handler is required.
  • When I search Google to see what rpm I need to get pcsc-ifd-handler, it looks like pcsc-ifd-handler is included in the ccid or pcsc-lite-openct package.

I already tried to install ccid and it needed pcsc-lite, so then I tried to install pcsc-lite-openct-0.6.19 and it also says it needs pcsc-lite.

So I'm kind of stuck in a cycle where the package that has pcsc-ifd-handler is dependent on pcsc-lite being installed, but pcsc-lite can't install until the package that contains pcsc-ifd-handler is installed.

Trying to install pcsc-lite on RHEL 6.6 but system is saying pcsc-ifd-handler is needed

I'm trying to follow this article:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Managing_Smart_Cards/enabling-smart-card-login.html

to enable smart card login on my RHEL 6.6 desktop. When I attempt to install coolkey-1.1.0, it says ccid and pcsc-lite is needed.

When attempt to install ccid-1.3.9.7, it says pcsc-lite is needed.

When I attempt to install pcsc-lite-1.5.2, it says pcsc-ifd-handler is required.

When I search Google to see what rpm I need to get pcsc-ifd-handler, it looks like pcsc-ifd-handler is included in the ccid or pcsc-lite-openct package (https://bugzilla.redhat.com/show_bug.cgi?id=144738).

I already tried to install ccid and it needed pcsc-lite, so then I tried to install pcsc-lite-openct-0.6.19 and it also says it needs pcsc-lite.

So I'm kind of stuck in a cycle where the package that has pcsc-ifd-handler is dependent on pcsc-lite being installed, but pcsc-lite can't install until the package that contains pcsc-ifd-handler is installed.

Installing RPM packages with circular dependency

I'm trying to follow an article to enable smart card login on my RHEL 6.6 desktop. When I attempt to install coolkey-1.1.0, it says ccid and pcsc-lite is needed.

  • When attempt to install ccid-1.3.9.7, it says pcsc-lite is needed.
  • When I attempt to install pcsc-lite-1.5.2, it says pcsc-ifd-handler is required.
  • When I search Google to see what rpm I need to get pcsc-ifd-handler, it looks like pcsc-ifd-handler is included in the ccid or pcsc-lite-openct package.

I already tried to install ccid and it needed pcsc-lite, so then I tried to install pcsc-lite-openct-0.6.19 and it also says it needs pcsc-lite.

So I'm kind of stuck in a cycle where the package that has pcsc-ifd-handler is dependent on pcsc-lite being installed, but pcsc-lite can't install until the package that contains pcsc-ifd-handler is installed.

1
source | link

Trying to install pcsc-lite on RHEL 6.6 but system is saying pcsc-ifd-handler is needed

I'm trying to follow this article:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Managing_Smart_Cards/enabling-smart-card-login.html

to enable smart card login on my RHEL 6.6 desktop. When I attempt to install coolkey-1.1.0, it says ccid and pcsc-lite is needed.

When attempt to install ccid-1.3.9.7, it says pcsc-lite is needed.

When I attempt to install pcsc-lite-1.5.2, it says pcsc-ifd-handler is required.

When I search Google to see what rpm I need to get pcsc-ifd-handler, it looks like pcsc-ifd-handler is included in the ccid or pcsc-lite-openct package (https://bugzilla.redhat.com/show_bug.cgi?id=144738).

I already tried to install ccid and it needed pcsc-lite, so then I tried to install pcsc-lite-openct-0.6.19 and it also says it needs pcsc-lite.

So I'm kind of stuck in a cycle where the package that has pcsc-ifd-handler is dependent on pcsc-lite being installed, but pcsc-lite can't install until the package that contains pcsc-ifd-handler is installed.