Podcast #128: We chat with Kent C Dodds about why he loves React and discuss what life was like in the dark days before Git. Listen now.
7 removed explicit GNOME dependence of the question: it applies to X in general
source | link

My preferred keyboard configuration is US-International. When I use it on MS-Windows and type certain special characters (i.e., ~ ' ") followed by a, o n I get á ó or ñ as I wish.

However when I type these characters followed by a letter that doesn't match, I will get that special character followed by the letter. So if I want to type, let's say, "q I can do it by pressing "q. However, if I do the same on Gnome I need to do it like "q, otherwise I get an audible bell.

Also, if I want to type two single quotes, in Gnome I need to type ' four times, instead of the two times it takes on MS-windows. I know it is a rather minor annoyance, but it does get to me, and I see Gnu+LinuxGNU+Linux as a highly customizable OS, and I'd like to learn more about how do I do such things. Changing to the normal US keyboard is not an option, because I need to use characters such as á ó or ñ for typing in Spanish.


note: I am using Debian

My preferred keyboard configuration is US-International. When I use it on MS-Windows and type certain special characters (i.e., ~ ' ") followed by a, o n I get á ó or ñ as I wish.

However when I type these characters followed by a letter that doesn't match, I will get that special character followed by the letter. So if I want to type, let's say, "q I can do it by pressing "q. However, if I do the same on Gnome I need to do it like "q, otherwise I get an audible bell.

Also, if I want to type two single quotes, in Gnome I need to type ' four times, instead of the two times it takes on MS-windows. I know it is a rather minor annoyance, but it does get to me, and I see Gnu+Linux as a highly customizable OS, and I'd like to learn more about how do I do such things. Changing to the normal US keyboard is not an option, because I need to use characters such as á ó or ñ for typing in Spanish.


note: I am using Debian

My preferred keyboard configuration is US-International. When I use it on MS-Windows and type certain special characters (i.e., ~ ' ") followed by a, o n I get á ó or ñ as I wish.

However when I type these characters followed by a letter that doesn't match, I will get that special character followed by the letter. So if I want to type, let's say, "q I can do it by pressing "q. However, if I do the same on Gnome I need to do it like "q, otherwise I get an audible bell.

Also, if I want to type two single quotes, in Gnome I need to type ' four times, instead of the two times it takes on MS-windows. I know it is a rather minor annoyance, but it does get to me, and I see GNU+Linux as a highly customizable OS, and I'd like to learn more about how do I do such things. Changing to the normal US keyboard is not an option, because I need to use characters such as á ó or ñ for typing in Spanish.


note: I am using Debian

6 removed explicit GNOME dependence of the question: it applies to X in general
| link

Tuning keyboard (dead key) functionality on Gnomein X

5 edited tags
| link
4 change focus from debian to gnome
source | link
3 format escapes
source | link
2 format escapes
source | link
1
source | link