2 replaced http://unix.stackexchange.com/ with https://unix.stackexchange.com/
source | link

As indicated in the comments, this is likely being caused by the UseDNS yes setting in the sshd_config on the server.

The UseDNS setting is a common culprit for this very issue. Basically what happens is that your IP netblock either has a defective, or missing DNS server. So sshd is trying to do a reverse lookup on your IP address, and waits until it times out. Other people do not experience the delay as they have a functional DNS server for their netblock.

Most people turn this setting off for this very reason. While yes, the setting is there for security, it is pretty much uselessit is pretty much useless.

The solution is simply to set the following in the sshd_config:

UseDNS no

As indicated in the comments, this is likely being caused by the UseDNS yes setting in the sshd_config on the server.

The UseDNS setting is a common culprit for this very issue. Basically what happens is that your IP netblock either has a defective, or missing DNS server. So sshd is trying to do a reverse lookup on your IP address, and waits until it times out. Other people do not experience the delay as they have a functional DNS server for their netblock.

Most people turn this setting off for this very reason. While yes, the setting is there for security, it is pretty much useless.

The solution is simply to set the following in the sshd_config:

UseDNS no

As indicated in the comments, this is likely being caused by the UseDNS yes setting in the sshd_config on the server.

The UseDNS setting is a common culprit for this very issue. Basically what happens is that your IP netblock either has a defective, or missing DNS server. So sshd is trying to do a reverse lookup on your IP address, and waits until it times out. Other people do not experience the delay as they have a functional DNS server for their netblock.

Most people turn this setting off for this very reason. While yes, the setting is there for security, it is pretty much useless.

The solution is simply to set the following in the sshd_config:

UseDNS no
1
source | link

As indicated in the comments, this is likely being caused by the UseDNS yes setting in the sshd_config on the server.

The UseDNS setting is a common culprit for this very issue. Basically what happens is that your IP netblock either has a defective, or missing DNS server. So sshd is trying to do a reverse lookup on your IP address, and waits until it times out. Other people do not experience the delay as they have a functional DNS server for their netblock.

Most people turn this setting off for this very reason. While yes, the setting is there for security, it is pretty much useless.

The solution is simply to set the following in the sshd_config:

UseDNS no