Bumped by Community user
    Bumped by Community user
    Bumped by Community user
    Bumped by Community user
    Bumped by Community user
    Bumped by Community user
    Bumped by Community user
    Bumped by Community user
    Bumped by Community user
    Bumped by Community user
    Bumped by Community user
    Bumped by Community user
    Bumped by Community user
    Tweeted twitter.com/#!/StackUnix/status/543293668564942848
2 added 55 characters in body
source | link

I'm using Opensuse 12.3.
systemd-195-13.45.1.x86_64

After few problems when I added a disc at btrfs mount I'm trying put my system in emergency mode (which I consider all services will be stopped and all mounts able to be unmounted),.

But they just don't work!!!

How to force systemd enter in emergency mode? (or something equivalent of init single mode) and force the emergency mode at boot time(grub menu)?

First attempt:
I use the old way : init 1 at the console...
They show me the emergency screen , ask for root password, but after this re-login, I still unable to unmount my btrfs FS (says it are in use). (with lsof I don't found anything using this mounts).
The runlevel command return level 3... not 1...

Second attempt:
I run the command systemctl emergency which show me the "emergency screen" , ask for root password... and then finally show me runlevel = 1 . But I'm still not able to umount my btrfs FS....

Third attempt:
I reboot the machine and at grub screen I type 'e' to add the "emergency" word at the options. Where they give me a message like "emergency word is invalid". I try with "single" word and get the same behave....


My final solution was remove the automatically mount from fstab and reboot my system at normal mode. Then finally I able to run my check at btrfs Fs... but is very annoying because all services which depends this mount start give errors...

I'm using Opensuse 12.3.
systemd-195-13.45.1.x86_64

After few problems when I added a disc at btrfs mount I'm trying put my system in emergency mode (which I consider all services will be stopped and all mounts able to be unmounted),.

But they just don't work!!!

How to force systemd enter in emergency mode? (or something equivalent of init single mode)

First attempt:
I use the old way : init 1 at the console...
They show me the emergency screen , ask for root password, but after this re-login, I still unable to unmount my btrfs FS (says it are in use). (with lsof I don't found anything using this mounts).
The runlevel command return level 3... not 1...

Second attempt:
I run the command systemctl emergency which show me the "emergency screen" , ask for root password... and then finally show me runlevel = 1 . But I'm still not able to umount my btrfs FS....

Third attempt:
I reboot the machine and at grub screen I type 'e' to add the "emergency" word at the options. Where they give me a message like "emergency word is invalid". I try with "single" word and get the same behave....


My final solution was remove the automatically mount from fstab and reboot my system at normal mode. Then finally I able to run my check at btrfs Fs... but is very annoying because all services which depends this mount start give errors...

I'm using Opensuse 12.3.
systemd-195-13.45.1.x86_64

After few problems when I added a disc at btrfs mount I'm trying put my system in emergency mode (which I consider all services will be stopped and all mounts able to be unmounted),.

But they just don't work!!!

How to force systemd enter in emergency mode? (or something equivalent of init single mode) and force the emergency mode at boot time(grub menu)?

First attempt:
I use the old way : init 1 at the console...
They show me the emergency screen , ask for root password, but after this re-login, I still unable to unmount my btrfs FS (says it are in use). (with lsof I don't found anything using this mounts).
The runlevel command return level 3... not 1...

Second attempt:
I run the command systemctl emergency which show me the "emergency screen" , ask for root password... and then finally show me runlevel = 1 . But I'm still not able to umount my btrfs FS....

Third attempt:
I reboot the machine and at grub screen I type 'e' to add the "emergency" word at the options. Where they give me a message like "emergency word is invalid". I try with "single" word and get the same behave....


My final solution was remove the automatically mount from fstab and reboot my system at normal mode. Then finally I able to run my check at btrfs Fs... but is very annoying because all services which depends this mount start give errors...

1
source | link

How to force systemd enter in emergency mode?

I'm using Opensuse 12.3.
systemd-195-13.45.1.x86_64

After few problems when I added a disc at btrfs mount I'm trying put my system in emergency mode (which I consider all services will be stopped and all mounts able to be unmounted),.

But they just don't work!!!

How to force systemd enter in emergency mode? (or something equivalent of init single mode)

First attempt:
I use the old way : init 1 at the console...
They show me the emergency screen , ask for root password, but after this re-login, I still unable to unmount my btrfs FS (says it are in use). (with lsof I don't found anything using this mounts).
The runlevel command return level 3... not 1...

Second attempt:
I run the command systemctl emergency which show me the "emergency screen" , ask for root password... and then finally show me runlevel = 1 . But I'm still not able to umount my btrfs FS....

Third attempt:
I reboot the machine and at grub screen I type 'e' to add the "emergency" word at the options. Where they give me a message like "emergency word is invalid". I try with "single" word and get the same behave....


My final solution was remove the automatically mount from fstab and reboot my system at normal mode. Then finally I able to run my check at btrfs Fs... but is very annoying because all services which depends this mount start give errors...