16 reputation
14
bio website
location
age
visits member for 2 years, 2 months
seen Sep 24 '12 at 20:36

Nov
10
awarded  Notable Question
Jun
24
awarded  Popular Question
Sep
24
comment Samba — Can't write to a share with “unix extensions = no” set in smb.conf
Doesn't work for me. If I add follow symlinks = yes,wide links = yes and allow insecure wide links = yes, I still can only cd into symlinks pointing to folders inside the share, not symlinks pointing to folders outside the share.
Sep
24
comment Samba — Can't write to a share with “unix extensions = no” set in smb.conf
The problem with turning unix extensions on is that then it's not possible to follow symlinks outside the share folder :(. Hmm I just don't know why I cannot write into a folder with unix extensions off -- so weird.
Sep
24
awarded  Commentator
Sep
24
comment Samba — Can't write to a share with “unix extensions = no” set in smb.conf
I stripped everything ldap-related from your config, changed the user and paths and added 'unix extensions = no' -- it still doesn't allow write access :(. I really don't know what to try anymore ... I have been trying to solve this for at least a week now :(
Sep
24
comment Samba — Can't write to a share with “unix extensions = no” set in smb.conf
But there's no 'unix extensions = no' in your config?
Sep
24
comment Samba — Can't write to a share with “unix extensions = no” set in smb.conf
Btw: You have quite an impressive config there :)
Sep
24
comment Samba — Can't write to a share with “unix extensions = no” set in smb.conf
Well, in the end I want to have a shared directory which allows Linux and Windows clients write access and allows the owner of the shared directory to symlink files and directories in other places into the shared directory. these symlinks should be accessible for clients like normal directories/files. I don't know anything of NFS -- would that be possible with NFS too?
Sep
24
comment Samba — Can't write to a share with “unix extensions = no” set in smb.conf
Yes, I saw the registry-thingys in the logs too ^^ My OS is Linux. Thank you
Sep
24
comment Samba — Can't write to a share with “unix extensions = no” set in smb.conf
I deleted all logs, restarted smbd, mounted the share and tried to create a folder ("Permission denied") and tried to create a file ("Permission denied"), then unmounted the share. Then posted the log. So it should contain everything relevant. Windows is not involved. May I ask for your smb.conf to test it with my user?
Sep
23
revised Samba — Can't write to a share with “unix extensions = no” set in smb.conf
deleted 4608 characters in body
Sep
23
revised Samba — Can't write to a share with “unix extensions = no” set in smb.conf
added 6522 characters in body
Sep
23
comment Samba — Can't write to a share with “unix extensions = no” set in smb.conf
Ok, now the log is giant! but there's nothing I can make sense of! I'll paste it into the question.
Sep
23
comment Samba — Can't write to a share with “unix extensions = no” set in smb.conf
I don't think that helps, but all that is logged by smbd is: "standard input is not a socket, assuming -D option" when starting up -- I guess there should be more !?
Sep
23
comment Samba — Can't write to a share with “unix extensions = no” set in smb.conf
Well -- there seems to be nothing in the log -- but I'm not completely sure since I'm using systemd/journalctl without syslog-ng and I'm not sure if that is logging samba correctly (I switched a few days ago). I will try to figure this out asap
Sep
23
comment Samba — Can't write to a share with “unix extensions = no” set in smb.conf
Thank you for replying! Unfortunately this doesn't work for me :(. I copied your example as is (I just changed the path, username and group) and restarted smbd but no success :(
Sep
23
revised Samba — Can't write to a share with “unix extensions = no” set in smb.conf
added 7 characters in body
Sep
23
awarded  Editor
Sep
23
awarded  Student