Reputation
308
Top tag
Next privilege 500 Rep.
Access review queues
Badges
1 16
Impact
~5k people reached

Aug
19
comment How to safely turn off swap permanently? (on Debian Jessie)
@burian.vlastimil Please post the entire contents of your /etc/fstab.
Aug
19
comment How to safely turn off swap permanently? (on Debian Jessie)
@burian.vlastimil Then, in my opinion, you have very few options left. If I was faced with this problem on my computer, I would now delete the partition and regenerate grub/initramfs. And I would make sure that I was choosing the correct kernel version in the GRUB menu. If you delete the swap, make sure you have a Linux live CD on hand, just in case.
Aug
19
comment How to safely turn off swap permanently? (on Debian Jessie)
@burian.vlastimil As long as you are regenerating it before rebooting, after deleting the file, you do not need to bother simulating it in a VM first.
Aug
19
comment How to safely turn off swap permanently? (on Debian Jessie)
@burian.vlastimil Then delete that version of the initramfs -- after all, you will be promptly recreating it. It will be in /boot, and named something like initramfs-3.16.0-4-amd64.img. If it starts with initrd or initramfs and includes 3.16.0-4-amd64, then delete it.
Aug
19
comment How to safely turn off swap permanently? (on Debian Jessie)
@burian.vlastimil No, the kernel version is the output of uname -r. And yes, try it without deleting the swap partition first.
Aug
19
comment How to safely turn off swap permanently? (on Debian Jessie)
@burian.vlastimil You could try running that new initramfs command without deleting the swap partition, and see if by any chance that fixes it.
Aug
19
revised How to safely turn off swap permanently? (on Debian Jessie)
added 211 characters in body
Aug
19
comment How to safely turn off swap permanently? (on Debian Jessie)
@burian.vlastimil I'm not sure about the command you used to regenerate the initramfs. See my edit.
Aug
19
comment How to safely turn off swap permanently? (on Debian Jessie)
@burian.vlastimil Yes, I only said "should" because I have not tried it with Debian. However, if it doesn't work, that is then a fault of Debian, and maybe you should switch to Fedora, which does not include a non-existent swap partition in a newly generated initramfs. :)
Aug
19
answered How to safely turn off swap permanently? (on Debian Jessie)
May
25
awarded  Popular Question
Apr
1
answered while: command not found
Aug
19
comment sed whitespace matching confusion
I really did not post my real problem at first, just a portion of it. I thought I could figure out the main problem if I could get over the puzzling behavior of my first example.
Aug
19
comment sed whitespace matching confusion
I know about tr. I will forever regret the example I initially posted. I was specifically wondering how to replace a sequence of whitespace with one character, even though I did a poor job of explaining that.
Aug
16
awarded  Scholar
Aug
16
accepted sed whitespace matching confusion
Aug
16
comment sed whitespace matching confusion
@Leiaz Oh yes...been too long since I've studied regex. I do remember now about '+'.
Aug
16
comment sed whitespace matching confusion
@Leiaz Hmmm....didn't think of that. So how do I match one or more?
Aug
16
revised sed whitespace matching confusion
added 263 characters in body
Aug
16
awarded  Student