153 reputation
28
bio website alfps.wordpress.com
location Norway
age 52
visits member for 3 years, 1 month
seen Aug 15 at 15:36

I have a pretty good sense of quality.

I'm one of the moderators of the comp.lang.c++.moderated Usenet group.

I'm about the 75th recipient of the C++ gold badge here on Stack Overflow.

My contributions to the C++ FAQ are numerous, but I think my main contribution is the FAQ item about dynamic binding during initialization, DBDI, "Okay, but is there a way to simulate that behavior as if dynamic binding worked on the this object within my base class's constructor?". The text is Marshall Cline’s, not my original proposal. But I convinced him, through a lengthy e-mail discussion, to include that item, so I think of it as “my” FAQ item…

I’m sometimes present in the C++ lounge chat room here on Stack Overflow.


Nov
13
awarded  Scholar
Nov
13
accepted AltGr keys don't work with Ubuntu in VirtualBox
Nov
12
comment AltGr keys don't work with Ubuntu in VirtualBox
Well, it still works after renaming that file and rebooting. And the terminal still remembers old command history after reboot. With silly persistent dynamic states like that, I think it must be rather difficult to hunt down bugs: they can't be reliably reproduced in such an interfering environment. I think further evidence of that is how the bug about AltGr has gone yoyo: closed as resolved, re-opened, closed as resolved, re-opened, so on and on. So I think it would be a Good Idea(TM) to severely punish the person who introduced that persistence of settings & state. :-)
Nov
12
comment AltGr keys don't work with Ubuntu in VirtualBox
It is an interesting answer, using keycode 66. In my comment before you posted this answer, I noted that keycode 113, which I just copied and pasted from the net, works for that line. Now when I run xevas you suggest, it reports keycode 108. Yet the line I copied from the net works. So it apparently has nothing to do with the keycode. I changed it to 66, just for fun, and rebooted: it still works. So I conclude it's not something technically accurate at all, but evidently a Heisenbug in Ubuntu.
Nov
12
awarded  Student
Nov
12
comment AltGr keys don't work with Ubuntu in VirtualBox
I got the AltGr key working in Ubuntu. I just had to know that I should create a file called ".Xmodmap" and add this line: "keycode 113 = Mode_switch Multi_key". Which I found in a bug report about a similar issue, at bugs.launchpad.net/ubuntu/+source/xkeyboard-config/+bug/349487/…
Nov
12
asked AltGr keys don't work with Ubuntu in VirtualBox
Nov
12
awarded  Autobiographer